]> code.ossystems Code Review - openembedded-core.git/commitdiff
devtool.py: fix buildclean test
authorChangqing Li <changqing.li@windriver.com>
Fri, 20 Sep 2019 02:31:55 +0000 (10:31 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Sep 2019 12:01:17 +0000 (13:01 +0100)
when build with EXTERNALSRC, checksum of EXTERNALSRC is one of inputs
for generate sigdata of task do_compile. without change any source, the
sigdata will not changed, and buildclean task only do make clean, and
not clean stampfiles like clean task, so the stampfile keep there, then
do_compile after do_buildclean will not rerun, and targetfile
tempdir_mdadm/mdadm will not be generated, report below error:

AssertionError: '/tmp/devtoolqarxv8ct6u/mdadm' does not exist

Fix by add a comments in Makefile to trigger rebuild of compile task

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/selftest/cases/devtool.py

index a7c6005c6d2e8dbe0092ec75e495edcc77fe224b..3a25da2033bae3cebb7e99c440a6b20c8d0e1e51 100644 (file)
@@ -604,6 +604,7 @@ class DevtoolModifyTests(DevtoolBase):
             bitbake('mdadm m4 -c buildclean')
             assertNoFile(tempdir_mdadm, 'mdadm')
             assertNoFile(builddir_m4, 'src/m4')
+            runCmd('echo "#Trigger rebuild" >> %s/Makefile' % tempdir_mdadm)
             bitbake('mdadm m4 -c compile')
             assertFile(tempdir_mdadm, 'mdadm')
             assertFile(builddir_m4, 'src/m4')