Rebased nopolkit.patch.
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+++ /dev/null
-DESCRIPTION = "ConsoleKit is a framework for defining and tracking users, login sessions, and seats."
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-DEPENDS = "dbus"
-
-inherit gnome
-
-SRC_URI = "http://people.freedesktop.org/~mccann/dist/ConsoleKit-${PV}.tar.bz2 \
- file://nopolkit.patch;patch=1"
-S = "${WORKDIR}/ConsoleKit-${PV}"
-
-FILES_${PN} += "${libdir}/ConsoleKit ${datadir}/dbus-1 ${datadir}/PolicyKit"
-
-
-
-
--- /dev/null
+DESCRIPTION = "ConsoleKit is a framework for defining and tracking users, login sessions, and seats."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
+BUGTRACKER="https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3"
+
+DEPENDS = "dbus"
+
+inherit gnome
+
+SRC_URI = "http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-0.4.3.tar.bz2 \
+ file://nopolkit.patch;patch=1"
+S = "${WORKDIR}/ConsoleKit-${PV}"
+
+FILES_${PN} += "${libdir}/ConsoleKit ${datadir}/dbus-1 ${datadir}/PolicyKit"
+
+
+
+
-Index: ConsoleKit-0.3.0/configure.ac
+Index: ConsoleKit-0.4.3/configure.ac
===================================================================
---- ConsoleKit-0.3.0.orig/configure.ac 2009-05-22 12:53:27.000000000 +0100
-+++ ConsoleKit-0.3.0/configure.ac 2009-05-22 12:53:56.000000000 +0100
+--- ConsoleKit-0.4.3.orig/configure.ac 2010-10-26 22:34:03.000000000 +0800
++++ ConsoleKit-0.4.3/configure.ac 2010-11-28 15:28:26.000000000 +0800
@@ -55,10 +55,7 @@
gthread-2.0 >= $GLIB_REQUIRED_VERSION
)
-PKG_CHECK_MODULES(POLKIT,
-- polkit >= $POLKIT_REQUIRED_VERSION,
+- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
- have_polkit=yes,
- have_polkit=no)
+have_polkit=no