]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer1.0-python: do not supply unknown g-i options
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 27 Oct 2021 09:07:35 +0000 (11:07 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 28 Oct 2021 13:16:26 +0000 (14:16 +0100)
meson 0.60 turns unknown options into them hard errors, so instead of relying on g-i class
(where the options are mandatory) add g-i dependencies explicitly.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb

index 74dd15b3eb055da0b1c2c82361ff09005e5e1519..a32805d129892a2ef1f490f9da6763b856d12c64 100644 (file)
@@ -21,6 +21,14 @@ EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
 
 # gobject-introspection is mandatory and cannot be configured
 REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
-UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
 
-inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check
+inherit meson pkgconfig distutils3-base upstream-version-is-even features_check
+
+# Generating introspection data depends on a combination of native and target
+# introspection tools, and qemu to run the target tools.
+DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native prelink-native"
+
+# Even though introspection is disabled on -native, gobject-introspection package is still
+# needed for m4 macros.
+DEPENDS:append:class-native = " gobject-introspection-native"
+DEPENDS:append:class-nativesdk = " gobject-introspection-native"