]> code.ossystems Code Review - openembedded-core.git/commitdiff
gypsy_0.8.bb: Fix build with gcc 4.6
authorKhem Raj <raj.khem@gmail.com>
Wed, 4 May 2011 17:36:19 +0000 (10:36 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 May 2011 10:54:46 +0000 (11:54 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch [new file with mode: 0644]
meta/recipes-connectivity/gypsy/gypsy_0.8.bb

diff --git a/meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch b/meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch
new file mode 100644 (file)
index 0000000..d826970
--- /dev/null
@@ -0,0 +1,16 @@
+Index: gypsy-0.8/gypsy/gypsy-time.c
+===================================================================
+--- gypsy-0.8.orig/gypsy/gypsy-time.c
++++ gypsy-0.8/gypsy/gypsy-time.c
+@@ -156,10 +156,10 @@ get_property (GObject    *object,
+             GParamSpec *pspec)
+ {
+       GypsyTimePrivate *priv;
+-
+       priv = GET_PRIVATE (object);
+       switch (prop_id) {
+       case PROP_PATH:
++              g_value_set_string (value, priv->object_path);
+               break;
+       default:
index ab7f6b086a5eeb915073cb3601f88ba22c0ad5fe..f3d3fa7c288bc06d26adfc966c599e7cbff7fbd7 100644 (file)
@@ -13,9 +13,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
 SECTION = "x11"
 DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt"
 
-SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz" 
-
-PR = "r0"
+SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \
+           file://fix-unused-but-set-variable-warning.patch \
+          "
+PR = "r1"
 
 inherit autotools pkgconfig