]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: upgrade 0.181 -> 0.182
authorAlexander Kanavin <alex.kanavin@gmail.com>
Fri, 4 Dec 2020 20:07:21 +0000 (21:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 9 Dec 2020 12:15:17 +0000 (12:15 +0000)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/elfutils/elfutils_0.182.bb [moved from meta/recipes-devtools/elfutils/elfutils_0.181.bb with 98% similarity]
meta/recipes-devtools/elfutils/files/0001-musl-obstack-fts.patch
meta/recipes-devtools/elfutils/files/0002-musl-libs.patch
meta/recipes-devtools/elfutils/files/0003-musl-utils.patch
meta/recipes-devtools/elfutils/files/0004-Fix-error-on-musl.patch
meta/recipes-devtools/elfutils/files/0015-config-eu.am-do-not-use-Werror.patch

similarity index 98%
rename from meta/recipes-devtools/elfutils/elfutils_0.181.bb
rename to meta/recipes-devtools/elfutils/elfutils_0.182.bb
index 6c49a5fc263973937cbd8f169eb8ee5ec9722294..f63208d72ba8632422d27ddcaaa918318d48911b 100644 (file)
@@ -28,7 +28,7 @@ SRC_URI_append_libc-musl = " \
            file://0004-Fix-error-on-musl.patch \
            file://0015-config-eu.am-do-not-use-Werror.patch \
            "
-SRC_URI[sha256sum] = "29a6ad7421ec2acfee489bb4a699908281ead2cb63a20a027ce8804a165f0eb3"
+SRC_URI[sha256sum] = "ecc406914edf335f0b7fc084ebe6c460c4d6d5175bfdd6688c1c78d9146b8858"
 
 inherit autotools gettext ptest pkgconfig
 
index 67d4703c80fb4697ccb656d94604e06a7ea2eb44..ca7caf08d85e12c67a78fb6134eea2e439dc1ee4 100644 (file)
@@ -1,4 +1,4 @@
-From 1a62bb8e8f2cb0f180c749946a48114e8f391b55 Mon Sep 17 00:00:00 2001
+From dbaa05a519acfe4f6040784f5d4a28ca586c0fc4 Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Fri, 23 Aug 2019 10:17:25 +0800
 Subject: [PATCH] musl-obstack-fts
@@ -20,10 +20,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  3 files changed, 58 insertions(+), 4 deletions(-)
 
 diff --git a/configure.ac b/configure.ac
-index ab9c751..b057d86 100644
+index 53bab6a..dfea85e 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -538,6 +538,60 @@ else
+@@ -539,6 +539,60 @@ else
  fi
  AC_SUBST([argp_LDADD])
  
index 894e46c3c4468767b0bfe44de3de999233215cb5..c6f766f680f21065654ff7aec5491655c78ce166 100644 (file)
@@ -1,4 +1,4 @@
-From 2e1f8ca0b67c1d1991c14d509938c347e09bae94 Mon Sep 17 00:00:00 2001
+From f4ca9db9d38f865505322595a8a1e8f69d5bb87c Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Fri, 23 Aug 2019 10:18:47 +0800
 Subject: [PATCH] musl-libs
@@ -21,8 +21,8 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  lib/libeu.h                    |  1 +
  libdwfl/dwfl_error.c           |  9 +++++++++
  libdwfl/linux-kernel-modules.c |  1 +
- libelf/elf.h                   |  9 ++++++---
- 6 files changed, 44 insertions(+), 4 deletions(-)
+ libelf/elf.h                   |  7 +++++++
+ 6 files changed, 45 insertions(+), 1 deletion(-)
  create mode 100644 lib/error.h
 
 diff --git a/lib/error.h b/lib/error.h
@@ -104,7 +104,7 @@ index 7bcf61c..11dcc8b 100644
        return elf_errmsg (error & 0xffff);
      case OTHER_ERROR (LIBDW):
 diff --git a/libdwfl/linux-kernel-modules.c b/libdwfl/linux-kernel-modules.c
-index 0434f1e..5afaee8 100644
+index 6edb27f..f331e3c 100644
 --- a/libdwfl/linux-kernel-modules.c
 +++ b/libdwfl/linux-kernel-modules.c
 @@ -50,6 +50,7 @@
@@ -116,26 +116,24 @@ index 0434f1e..5afaee8 100644
  /* If fts.h is included before config.h, its indirect inclusions may not
     give us the right LFS aliases of these functions, so map them manually.  */
 diff --git a/libelf/elf.h b/libelf/elf.h
-index 197b557..8e5b94c 100644
+index 6439c1a..a87c589 100644
 --- a/libelf/elf.h
 +++ b/libelf/elf.h
-@@ -21,7 +21,9 @@
+@@ -19,6 +19,10 @@
+ #ifndef _ELF_H
+ #define       _ELF_H 1
  
- #include <features.h>
--__BEGIN_DECLS
 +#ifdef __cplusplus
 +extern "C" {
 +#endif
++
  /* Standard ELF types.  */
  
-@@ -4103,6 +4105,7 @@ enum
+ #include <stdint.h>
+@@ -4101,4 +4105,7 @@ enum
  #define R_ARC_TLS_LE_S9               0x4a
  #define R_ARC_TLS_LE_32               0x4b
  
--__END_DECLS
--
 +#ifdef __cplusplus
 +}
 +#endif
index 2a21cd37ced2775106cd8b1e393460ca31e7303e..a8b39b5f939e75a69c4e6b0097b3ef0a64ec9ba6 100644 (file)
@@ -1,4 +1,4 @@
-From 9b237f19f82d5ab1e0702637fece1866b1ef6681 Mon Sep 17 00:00:00 2001
+From e7e5333ed2e19f25ecbd7121f424eec99d61265a Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Fri, 23 Aug 2019 10:19:48 +0800
 Subject: [PATCH] musl-utils
@@ -58,7 +58,7 @@ index 6ba6af4..0c7674b 100644
  ARGP_PROGRAM_VERSION_HOOK_DEF = print_version;
  
 diff --git a/src/readelf.c b/src/readelf.c
-index 685d0b1..a842b10 100644
+index 64067a5..630739c 100644
 --- a/src/readelf.c
 +++ b/src/readelf.c
 @@ -4829,10 +4829,11 @@ listptr_base (struct listptr *p)
@@ -142,7 +142,7 @@ index 48792a7..198a2e4 100644
  
  /* Name and version of program.  */
 diff --git a/src/unstrip.c b/src/unstrip.c
-index 9b8c09a..1fb5063 100644
+index a855038..df6fc1c 100644
 --- a/src/unstrip.c
 +++ b/src/unstrip.c
 @@ -56,6 +56,15 @@
index c79c737c62bbe8a8c7b615e500367554d3d7779d..0d162ebe1b146ee4aa43cf8596fb29645126462d 100644 (file)
@@ -1,4 +1,4 @@
-From d3dc5f98f653342af97ebfbdf3479ee1f0d0cf38 Mon Sep 17 00:00:00 2001
+From ed87f11f7297c0edb3ca8950de1cc23e9b96217c Mon Sep 17 00:00:00 2001
 From: Richard Purdie <richard.purdie@linuxfoundation.org>
 Date: Wed, 1 May 2019 22:15:03 +0100
 Subject: [PATCH] Fix error on musl:
index 48fd4d41f381661fdc0574bbb685a3f4efa86f42..ec1b927c2e62e8068da154b3baacc5eeb42f5839 100644 (file)
@@ -1,4 +1,4 @@
-From 9b7554a3e21ccb455b3661a6b4e767636c2c5cf3 Mon Sep 17 00:00:00 2001
+From 574ac484c01125a97ba8737cf7292ca926897310 Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Mon, 22 Jun 2020 21:35:16 +0000
 Subject: [PATCH] config/eu.am: do not use -Werror