]> code.ossystems Code Review - openembedded-core.git/commitdiff
gettext: Get gettext use its own libunistring
authorWenzong Fan <wenzong.fan@windriver.com>
Tue, 14 Feb 2012 01:42:59 +0000 (09:42 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Feb 2012 12:14:52 +0000 (12:14 +0000)
According to its documentation, gettext 0.18.1.1 needs either
libunistring or it will use its own internal version. Just add
a configure option '--with-included-libunistring' to force the
latter to avoid races.

[YOCTO#1934]

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
meta/recipes-core/gettext/gettext_0.18.1.1.bb

index 615582ee5ea0332e3c8b7e94837b83bf7ee2643a..3c65dca11f8b098abc3053476a47359f47f00794 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 LICENSE = "GPL-3+ & LGPL-2.1+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
-PR = "r6"
+PR = "r7"
 DEPENDS = "libxml2-native gettext-native virtual/libiconv ncurses expat"
 DEPENDS_virtclass-native = "libxml2-native"
 PROVIDES = "virtual/libintl virtual/gettext"
@@ -38,6 +38,7 @@ EXTRA_OECONF += "--without-lispdir \
                  --without-git \
                  --with-included-libxml \
                  --with-included-libcroco \
+                 --with-included-libunistring \
                 "
 
 acpaths = '-I ${S}/gettext-runtime/m4 \