]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr/apr-util: Fix some other config path gremlins breaking builds
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 12 Jan 2009 17:34:52 +0000 (17:34 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 12 Jan 2009 17:34:52 +0000 (17:34 +0000)
meta/packages/apr/apr-util/configfix.patch [new file with mode: 0644]
meta/packages/apr/apr-util_1.3.4.bb
meta/packages/apr/apr/configfix.patch
meta/packages/apr/apr_1.3.3.bb
meta/packages/subversion/subversion_1.5.5.bb

diff --git a/meta/packages/apr/apr-util/configfix.patch b/meta/packages/apr/apr-util/configfix.patch
new file mode 100644 (file)
index 0000000..a8953e5
--- /dev/null
@@ -0,0 +1,49 @@
+Index: apr-util-1.3.4/apu-config.in
+===================================================================
+--- apr-util-1.3.4.orig/apu-config.in  2009-01-12 17:08:06.000000000 +0000
++++ apr-util-1.3.4/apu-config.in       2009-01-12 17:09:00.000000000 +0000
+@@ -134,14 +134,7 @@
+     exit 0
+     ;;
+     --includes)
+-    if test "$location" = "installed"; then
+         flags="$flags -I$includedir $INCLUDES"
+-    elif test "$location" = "source"; then
+-        flags="$flags -I$APU_SOURCE_DIR/include $INCLUDES"
+-    else
+-        # this is for VPATH builds
+-        flags="$flags -I$APU_BUILD_DIR/include -I$APU_SOURCE_DIR/include $INCLUDES"
+-    fi
+     ;;
+     --ldflags)
+     flags="$flags $LDFLAGS"
+@@ -155,28 +148,10 @@
+     exit 0
+     ;;
+     --link-ld)
+-    if test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+         flags="$flags -L$libdir -l$APRUTIL_LIBNAME"
+-    else
+-        flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME"
+-    fi
+     ;;
+     --link-libtool)
+-    # If the LA_FILE exists where we think it should be, use it.  If we're
+-    # installed and the LA_FILE does not exist, assume to use -L/-l
+-    # (the LA_FILE may not have been installed).  If we're building ourselves,
+-    # we'll assume that at some point the .la file be created.
+-    if test -f "$LA_FILE"; then
+-        flags="$flags $LA_FILE"
+-    elif test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+-        # Since the user is specifying they are linking with libtool, we
+-        # *know* that -R will be recognized by libtool.
+-        flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME"
+-    else
+-        flags="$flags $LA_FILE"
+-    fi
++        flags="$flags -l$APRUTIL_LIBNAME"
+     ;;
+     --apu-la-file)
+     if test -f "$LA_FILE"; then
index 2c9432a15755727338fda6b8b04ad1bde23625c4..f2d5470977cbcd961b13ec02ffe19dd9cc1003b7 100644 (file)
@@ -3,9 +3,10 @@ SECTION = "libs"
 DEPENDS = "apr expat gdbm"
 LICENSE = "Apache License, Version 2.0"
 
-PR = "r3"
+PR = "r5"
 
 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+           file://configfix.patch;patch=1 \
            file://configure_fixes.patch;patch=1"
 
 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ 
index ec46172c6dbfd3365ee3cb2db74e2a139ef35923..995555e8baa6b24e558d50f9207d2837bfe388f1 100644 (file)
@@ -45,7 +45,7 @@ Index: apr-1.3.3/apr-config.in
 -    else
 -        flags="$flags $LA_FILE"
 -    fi
-+        flags="$flags ll${APR_LIBNAME}"
++        flags="$flags -l${APR_LIBNAME}"
      ;;
      --shlib-path-var)
      echo "$SHLIBPATH_VAR"
index ac25246bee2a9fff51ff5dfb6d8760828a6db500..4b4ce1118dca2120d7fae498e61ba31f55456eb7 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
 SECTION = "libs"
 LICENSE = "Apache License, Version 2.0"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
            file://configure_fixes.patch;patch=1 \
index 4a1153ce0bd0fd458408f1b7922ccec2d748a869..a1c0f94558f63852bc79f6f752edbff1796f167c 100644 (file)
@@ -5,7 +5,7 @@ RDEPENDS = "neon"
 LICENSE = "Apache BSD"
 HOMEPAGE = "http://subversion.tigris.org"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
            file://disable-revision-install.patch;patch=1 \