]> code.ossystems Code Review - openembedded-core.git/commitdiff
beecrypt: Fix multilib header conflict - beecrypt/gnu.h
authorMark Hatle <mark.hatle@windriver.com>
Tue, 26 Jul 2011 17:59:49 +0000 (12:59 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 14:39:17 +0000 (15:39 +0100)
beecrypt/gnu.h conflicts between 32-bit and 64-bit versions.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-support/beecrypt/beecrypt_4.2.1.bb

index f6606413b13e8aa6f5930a3b1336913c9e5025b5..2913b46f10b6034c1a5d6a018e2b7868c0658d9c 100644 (file)
@@ -17,11 +17,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9894370afd5dfe7d02b8d14319e729a1 \
 
 DEPENDS = "icu"
 
-PR = "r0"
+PR = "r1"
 
-inherit autotools
+inherit autotools multilib_header
 acpaths=""
 
+do_install_append() {
+       oe_multilib_header beecrypt/gnu.h
+}
+
 EXTRA_OECONF="--without-python --enable-shared --enable-static --disable-openmp"
 
 FILES_${PN} = "${sysconfdir} ${libdir}/*.so.* ${libdir}/${BPN}/*.so.*"