]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-subunit: add it for oeqa
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 27 Jul 2018 07:36:17 +0000 (15:36 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Jul 2018 11:44:28 +0000 (12:44 +0100)
- It is required by oeqa, add it so that we can add nativesdk-python3-subunit
  to buildtools-tarball.
- The original one is python-subunit_1.1.0.bb which is from meta-openstack
  layer, I divided it into python-subunit.inc and python3-subunit_1.1.0.bb
  and extended to nativesdk.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-subunit.inc [new file with mode: 0644]
meta/recipes-devtools/python/python3-subunit_1.1.0.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python-subunit.inc b/meta/recipes-devtools/python/python-subunit.inc
new file mode 100644 (file)
index 0000000..f893e7a
--- /dev/null
@@ -0,0 +1,14 @@
+SUMMARY = "Python implementation of subunit test streaming protocol"
+HOMEPAGE = "https://pypi.python.org/pypi/python-subunit/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README;md5=e5b524e1b2c67c88fc64439ee4a850aa"
+
+PYPI_PACKAGE = "python-subunit"
+
+SRC_URI[md5sum] = "d2c09c93346077ced675c9f718e6a0f1"
+SRC_URI[sha256sum] = "d9a7606e9610828d68c1d2f0f5abbb421e34e518b8f4882c8b2e08176281bf88"
+
+inherit pypi
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-subunit_1.1.0.bb b/meta/recipes-devtools/python/python3-subunit_1.1.0.bb
new file mode 100644 (file)
index 0000000..2ece445
--- /dev/null
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-subunit.inc