]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add chroot scripts to qemu-config package
authorRichard Purdie <richard@openedhand.com>
Wed, 30 Jan 2008 15:36:14 +0000 (15:36 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 30 Jan 2008 15:36:14 +0000 (15:36 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3626 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oh/qemu-config.bb
meta/packages/oh/qemu-config/poky-chroot-init [new file with mode: 0755]
meta/packages/oh/qemu-config/poky-chroot-launch [new file with mode: 0755]

index 741fb8942242430a1c65db47ebb635c42b23ab0d..3eccab99e19ab028fe8fbd9b9dcf2e439c673c96 100644 (file)
@@ -1,13 +1,15 @@
 DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
 LICENSE = "GPL"
 RDEPENDS = "distcc task-poky-nfs-server fakeroot oprofileui-server rsync bash"
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "file://distcc.sh \
            file://anjuta-remote-run \
            file://exports \
-          file://shutdown.desktop \
-          file://shutdown.png \
+           file://shutdown.desktop \
+           file://shutdown.png \
+           file://poky-chroot-init \
+           file://poky-chroot-launch \
            file://qemu-autostart"
 
 S = "${WORKDIR}"
@@ -23,6 +25,8 @@ do_install() {
     
     install -d ${D}${bindir}
     install -m 0755 anjuta-remote-run ${D}${bindir}/
+    install -m 0775 poky-chroot-init ${D}${bindir}/
+    install -m 0775 poky-chroot-launch ${D}${bindir}/
     
     install -d ${D}${datadir}/applications
     install -m 0644 shutdown.desktop ${D}${datadir}/applications/
@@ -31,7 +35,7 @@ do_install() {
     install -m 0644 shutdown.png ${D}${datadir}/pixmaps/
 
     install -d ${D}/etc/init.d
-    install qemu-autostart ${D}/etc/init.d
+    install qemu-autostart ${D}/etc/init.d/
 }
 
 inherit update-rc.d
diff --git a/meta/packages/oh/qemu-config/poky-chroot-init b/meta/packages/oh/qemu-config/poky-chroot-init
new file mode 100755 (executable)
index 0000000..0afa505
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+export USER=root
+export HOME=/home/root
+export PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+fakeroot ipkg configure
diff --git a/meta/packages/oh/qemu-config/poky-chroot-launch b/meta/packages/oh/qemu-config/poky-chroot-launch
new file mode 100755 (executable)
index 0000000..63d98d9
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/bash
+
+export USER=root
+export HOME=/home/root
+export PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+export DISPLAY=:1
+
+unset DBUS_SESSION_BUS_ADDRESS
+
+SERVICES=dbus-1
+
+for S in $SERVICES; do
+        fakeroot /etc/init.d/$S start
+done
+
+/etc/X11/Xsession &
+
+bash -l
+
+for S in $SERVICES; do
+        fakeroot /etc/init.d/$S stop
+done
+
+# The --user option in the dbus stop script breaks under chroot
+/sbin/start-stop-daemon --stop  --pidfile /var/run/dbus/pid