]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pycurl: build docstrings to fix rebuilds
authorRoss Burton <ross.burton@intel.com>
Tue, 9 Dec 2014 15:05:35 +0000 (15:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Dec 2014 11:26:08 +0000 (11:26 +0000)
On a rebuild base.bbclass will invoke "make clean" to ensure that old build
objects are not used. This will delete docstrings.c and the only way to
re-generate that is with a dedicated setup.py target.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-pycurl_7.19.5.bb

index a21a426dbb109395b2a0198ee2b3573cc1fba272..e4619c740e7b394497373221f93df3198d595287 100644 (file)
@@ -29,6 +29,11 @@ export STAGING_LIBDIR
 
 BBCLASSEXTEND = "native"
 
+# Ensure the docstrings are generated as make clean will remove them
+do_compile_prepend() {
+       ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
+}
+
 do_install_append() {
        rm -rf ${D}${datadir}/share
 }