]> code.ossystems Code Review - openembedded-core.git/commitdiff
opensp: improve configuration and install steps
authorScott Garman <scott.a.garman@intel.com>
Wed, 16 Feb 2011 00:36:12 +0000 (16:36 -0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 16 Feb 2011 15:45:19 +0000 (07:45 -0800)
* For the -native case we need to point two configure
  options to the SGML catalogs in the native sysroot
* Some packages (e.g, iputils) use different names for
  the openSP utilities, so create these names as
  symlinks after do_install

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/opensp/opensp_1.5.bb

index bda87cb06dff8fbd6e8549c66153e350a60bb1d8..61022e037bec54f630dd3ba867f2d4118f547ab4 100644 (file)
@@ -24,4 +24,22 @@ S = "${WORKDIR}/OpenSP-${PV}"
 
 inherit autotools gettext
 
+EXTRA_OECONF_virtclass-native = "\
+       --enable-default-catalog=${sysconfdir}/sgml/catalog \
+       --enable-default-search-path=${datadir}/sgml \
+       "
+
+do_install_append() {
+       # Set up symlinks to often-used alternate names. See
+       # http://www.linuxfromscratch.org/blfs/view/stable/pst/opensp.html
+       cd ${D}${libdir}
+       ln -sf libosp.so libsp.so
+
+       cd ${D}${bindir}
+       for util in nsgmls sgmlnorm spam spcat spent sx; do
+               ln -sf o$util $util     
+       done
+       ln -sf osx sgml2xml
+}
+
 BBCLASSEXTEND = "native"