]> code.ossystems Code Review - openembedded-core.git/commitdiff
diffutils: refactor to add a common diffutils.inc
authorSaul Wold <sgw@linux.intel.com>
Thu, 26 Jul 2012 23:18:48 +0000 (16:18 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 15 Aug 2012 13:18:39 +0000 (14:18 +0100)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/diffutils/diffutils.inc [new file with mode: 0644]
meta/recipes-extended/diffutils/diffutils_2.8.1.bb
meta/recipes-extended/diffutils/diffutils_3.2.bb

diff --git a/meta/recipes-extended/diffutils/diffutils.inc b/meta/recipes-extended/diffutils/diffutils.inc
new file mode 100644 (file)
index 0000000..3964db0
--- /dev/null
@@ -0,0 +1,22 @@
+SUMMARY = "Diffutils contains tools used for finding differences between files."
+DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
+sdiff, and cmp utilities. These programs are usually \
+used for creating patch files."
+SECTION = "base"
+
+INC_PR = "r6"
+
+SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz"
+
+inherit autotools update-alternatives gettext
+
+# diffutils assumes non-glibc compilation with uclibc and
+# this causes it to generate its own implementations of
+# standard functionality.  regex.c actually breaks compilation
+# because it uses __mempcpy, there are other things (TBD:
+# see diffutils.mk in buildroot)
+EXTRA_OECONF_libc-uclibc = "--without-included-regex"
+
+ALTERNATIVE_LINKS = "${bindir}/diff ${bindir}/cmp"
+ALTERNATIVE_PRIORITY = "100"
+
index 09eb71e66552922564ec3aa503dc35f8b728f949..a31363aefb7d55060cf0b237b83eb7fd2b976a56 100644 (file)
@@ -1,28 +1,12 @@
-SUMMARY = "Diffutils contains tools used for finding differences between files."
-DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
-sdiff, and cmp utilities. These programs are usually \
-used for creating patch files."
-SECTION = "base"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
-PR = "r5"
+require diffutils.inc
 
-SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
-           file://diffutils_fix_for_automake-1.12.patch \
-           "
+PR = "${INC_PR}.0"
+
+SRC_URI += "file://diffutils_fix_for_automake-1.12.patch"
 
 SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428"
 SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a"
 
-inherit autotools update-alternatives gettext
-
-# diffutils assumes non-glibc compilation with uclibc and
-# this causes it to generate its own implementations of
-# standard functionality.  regex.c actually breaks compilation
-# because it uses __mempcpy, there are other things (TBD:
-# see diffutils.mk in buildroot)
-EXTRA_OECONF_libc-uclibc = "--without-included-regex"
-
-ALTERNATIVE_LINKS = "${bindir}/diff ${bindir}/cmp"
-ALTERNATIVE_PRIORITY = "100"
index c46863d3a7c3f10a673e55729c51e00052868615..74c371dc9eb3d04f6efe4168ace2d1d0b1be5b06 100644 (file)
@@ -1,27 +1,11 @@
-DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
-sdiff, and cmp utilities. These programs are usually \
-used for creating patch files."
-SECTION = "base"
 LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
-PR = "r1"
+require diffutils.inc
 
-SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
-           file://remove-gets.patch \
-          "
+PR = "${INC_PR}.0"
 
-inherit autotools update-alternatives gettext
-
-# diffutils assumes non-glibc compilation with uclibc and
-# this causes it to generate its own implementations of
-# standard functionality.  regex.c actually breaks compilation
-# because it uses __mempcpy, there are other things (TBD:
-# see diffutils.mk in buildroot)
-EXTRA_OECONF_libc-uclibc = "--without-included-regex"
-
-ALTERNATIVE_LINKS = "${bindir}/diff ${bindir}/cmp"
-ALTERNATIVE_PRIORITY = "100"
+SRC_URI += "file://remove-gets.patch"
 
 SRC_URI[md5sum] = "22e4deef5d8949a727b159d6bc65c1cc"
 SRC_URI[sha256sum] = "2aaaebef615be7dc365306a14caa5d273a4fc174f9f10abca8b60e082c054ed3"