]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdbm: Resolve host contamination issue
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2012 21:39:36 +0000 (21:39 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2012 21:44:51 +0000 (22:44 +0100)
The autoconf macros detect the presence of -ldbm or -lndbm on the host
system and add the library to link against, for now good reason I can
explain.

This patch makes the build behave determinstically whether they're
present or not. Other than the extra linkage, there doesn't appear to be
any other change in behaviour from these options and they look like
dead code.

The extra linkage can cause problems where sstate is used on a machine
where the extra librbary isn't present causing build failures.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gdbm/gdbm_1.10.bb

index 6b68d27ccef0084ed568694977fcaf2a05ec6238..498ad9985e6c6e5b864440e3d1308f352e928051 100644 (file)
@@ -16,6 +16,9 @@ inherit autotools gettext lib_package
 # Needed for dbm python module
 EXTRA_OECONF = "-enable-libgdbm-compat"
 
+# Stop presence of dbm/nbdm on the host contaminating builds
+CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
+
 BBCLASSEXTEND = "native nativesdk"
 
 do_install_append () {