]> code.ossystems Code Review - openembedded-core.git/commitdiff
distutils/steuptools: Fix files layout and unbreak builds
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 Aug 2012 16:12:39 +0000 (16:12 +0000)
committerScott Garman <scott.a.garman@intel.com>
Mon, 24 Sep 2012 16:51:09 +0000 (09:51 -0700)
The last two distutils changes progressivly broke the builds. Firstly they
moved things from the site_packages directory to being higher up the tree
which introduced package QA warnings as a side effect. Secondly, it interacts
badly with setuptools which passes in --root=${D} itself.

This patch restores the original directory layout, hence fixing the QA
warnings and also passes extra options to setuptools to deal with the
--root option it passes.

(From OE-Core rev: bed18d5df7915e4127a538be9c7550e185c8c850)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/distutils.bbclass
meta/classes/setuptools.bbclass

index ec471babd7f60c8afba7517cbf3d8ac0532caa8c..1f097a8c4b0096ee65195c08c7cc7c7452dfc582 100644 (file)
@@ -38,7 +38,7 @@ distutils_do_install() {
         STAGING_LIBDIR=${STAGING_LIBDIR} \
         PYTHONPATH=${D}/${PYTHON_SITEPACKAGES_DIR} \
         BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-        ${STAGING_BINDIR_NATIVE}/python setup.py install --install-lib=${D}${libdir}/${PYTHON_DIR} ${DISTUTILS_INSTALL_ARGS}|| \
+        ${STAGING_BINDIR_NATIVE}/python setup.py install --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${DISTUTILS_INSTALL_ARGS} || \
         bbfatal "python setup.py install execution failed."
 
         for i in `find ${D} -name "*.py"` ; do \
index ced9509df236f4ea9e59625e25989ea6abf62592..ba9cf13295ac2e40a6cb96a6a1b6c1b1f396744b 100644 (file)
@@ -5,4 +5,5 @@ DEPENDS += "python-setuptools-native"
 DISTUTILS_INSTALL_ARGS = "--root=${D} \
     --single-version-externally-managed \
     --prefix=${prefix} \
+    --install-lib=${PYTHON_SITEPACKAGES_DIR} \
     --install-data=${datadir}"