]> code.ossystems Code Review - openembedded-core.git/commitdiff
efivar: ensure that target security flags are not used to build native code
authorRoss Burton <ross.burton@intel.com>
Mon, 1 Jul 2019 11:25:19 +0000 (12:25 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 2 Jul 2019 07:10:42 +0000 (08:10 +0100)
Also set LDFLAGS=BUILD_LDFLAGS when compiling makeguids to ensure that any
target compiler flags are not passed to the native compiler.

[ YOCTO #13423 ]

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/efivar/efivar_37.bb

index c4254c70d91388f07f826a410da1dcd64b3b9482..9b95721a4ecd84c6bc40461a73dc14e1abf45a35 100644 (file)
@@ -23,7 +23,10 @@ LDFLAGS += "-fuse-ld=bfd"
 
 do_compile_prepend() {
     # Remove when https://github.com/rhboot/efivar/issues/130 is fixed
-    oe_runmake CFLAGS="${BUILD_CFLAGS}" -C src makeguids
+    oe_runmake \
+        CFLAGS="${BUILD_CFLAGS}" \
+        LDFLAGS="${BUILD_LDFLAGS}" \
+        -C src makeguids
 }
 
 do_install() {