]> code.ossystems Code Review - openembedded-core.git/commitdiff
ofono: Fix missing python dependency and package tests separately
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Nov 2011 23:04:13 +0000 (23:04 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Nov 2011 11:38:38 +0000 (11:38 +0000)
We need to ensure there is a python dependency for the ofono python
test scripts. To do this without introducing the dependency
unnecessarily for the core ofono functionality, this patch splits
the tests into a separate package too.

[YOCTO #1705]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/ofono/ofono.inc
meta/recipes-connectivity/ofono/ofono_0.50.bb
meta/recipes-connectivity/ofono/ofono_git.bb

index 0b1a6e12345292aaa55ed94aae33ffc365be60c3..0cc58ae3a5702750ffb11ac86d8d59a4b0e8926e 100644 (file)
@@ -17,4 +17,8 @@ do_install_append() {
   install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
 }
 
+PACKAGES =+ "${PN}-tests"
+
 FILES_${PN} += "${base_libdir}/udev ${base_libdir}/systemd"
+FILES_${PN}-tests = "${libdir}/ofono"
+RDEPENDS_${PN}-tests = "python"
index b679200fb0c28d89b2b869d2208e68e8f891239a..b4ef413be7a8aac0ca02aafe52a89ff7c9d6d150 100644 (file)
@@ -1,6 +1,6 @@
 require ofono.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI  = "${KERNELORG_MIRROR}/linux/network/ofono/${BPN}-${PV}.tar.bz2 \
                  file://ofono"
index f1770c2d128c58d2fe309eb97c258b8b34e475e9..966d315df02fe9ac6026772b1d8aae96db2c5e6c 100644 (file)
@@ -1,6 +1,6 @@
 require ofono.inc
 
-PR = "r1"
+PR = "r2"
 
 S       = "${WORKDIR}/git"
 SRCREV = "14544d5996836f628613c2ce544380ee6fc8f514"