]> code.ossystems Code Review - openembedded-core.git/commitdiff
fix building of syncml-client and and the syncml-client-plugin
authorTomas Frydrych <tf@openedhand.com>
Tue, 9 Jan 2007 13:13:38 +0000 (13:13 +0000)
committerTomas Frydrych <tf@openedhand.com>
Tue, 9 Jan 2007 13:13:38 +0000 (13:13 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1136 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/opensync/libopensync-plugin-syncml-client-plugin-0.1/missing-syncml-config.patch [new file with mode: 0644]
meta/packages/opensync/libopensync-plugin-syncml-client-plugin-0.1/syncml-client-plugin-cpp.patch [new file with mode: 0644]
meta/packages/opensync/libopensync-plugin-syncml-client-plugin_0.1.bb
meta/packages/opensync/syncml-client-0.1/syncml-client-pc-in-cross.patch [new file with mode: 0644]
meta/packages/opensync/syncml-client-0.1/syncml-client-plugin-h.patch [new file with mode: 0644]
meta/packages/opensync/syncml-client_0.1.bb

diff --git a/meta/packages/opensync/libopensync-plugin-syncml-client-plugin-0.1/missing-syncml-config.patch b/meta/packages/opensync/libopensync-plugin-syncml-client-plugin-0.1/missing-syncml-config.patch
new file mode 100644 (file)
index 0000000..0fac67e
--- /dev/null
@@ -0,0 +1,8 @@
+--- tmp/src/missing-syncml-client-plugin       2007-01-09 12:55:48.000000000 +0000
++++ tmp/src/syncml-client-plugin       2007-01-09 12:55:48.000000000 +0000
+@@ -0,0 +1,5 @@
++<config>
++    <gconf-uri>/apps/syncml-client</gconf-uri>
++    <object-type>contact</object-type>
++    <sync-source-name>card</sync-source-name>
++</config>
diff --git a/meta/packages/opensync/libopensync-plugin-syncml-client-plugin-0.1/syncml-client-plugin-cpp.patch b/meta/packages/opensync/libopensync-plugin-syncml-client-plugin-0.1/syncml-client-plugin-cpp.patch
new file mode 100644 (file)
index 0000000..7b659ce
--- /dev/null
@@ -0,0 +1,11 @@
+--- tmp/src/syncml-client-plugin.cpp.orig      2007-01-09 12:27:33.000000000 +0000
++++ tmp/src/syncml-client-plugin.cpp   2007-01-09 12:27:33.000000000 +0000
+@@ -94,7 +94,7 @@
+ /**
+ * Initialize the plugin environment, read config data.
+ */
+-extern "C" static void* smc_initialize(OSyncMember *member, OSyncError **error)
++extern "C" void* smc_initialize(OSyncMember *member, OSyncError **error)
+ {
+     char *configData;
+     int  configSize;
index 9e4749183b29b9a1c1e4bc3bc2d96c7eb4d1e981..a81417bf7e9b69656685178e96463547c98ecc51 100644 (file)
@@ -1,9 +1,13 @@
+PR = "r1"
 
-SRC_URI = "svn://svn.opensync.org/plugins/syncml-client/plugin/tags;module=release-0.1;proto=http"
-S = "${WORKDIR}/release-0.1"
-PV = "0.1"
+SRC_URI = "svn://svn.opensync.org/plugins/syncml-client/plugin/tags;module=release-${PV};proto=http \
+       file://missing-syncml-config.patch;patch=1 \
+       file://syncml-client-plugin-cpp.patch;patch=1"
+
+
+S = "${WORKDIR}/release-${PV}"
 
 require libopensync-plugin.inc
 
-DEPENDS += " syncml-client"
+DEPENDS += "syncml-client"
 
diff --git a/meta/packages/opensync/syncml-client-0.1/syncml-client-pc-in-cross.patch b/meta/packages/opensync/syncml-client-0.1/syncml-client-pc-in-cross.patch
new file mode 100644 (file)
index 0000000..364f764
--- /dev/null
@@ -0,0 +1,10 @@
+--- tmp/syncml-client.pc.in.orig       2007-01-09 09:43:18.000000000 +0000
++++ tmp/syncml-client.pc.in    2007-01-09 09:43:18.000000000 +0000
+@@ -8,6 +8,6 @@
+ Version: @VERSION@
+ Requires: libcurl, gconf-2.0
+ Libs: @SYNCML_LIBS@ -lsyncmlclient
+-Cflags: @SYNCML_CFLAGS@ -I@includedir@/syncml-client
++Cflags: @SYNCML_CFLAGS@ -I${includedir}/syncml-client
+ ~
diff --git a/meta/packages/opensync/syncml-client-0.1/syncml-client-plugin-h.patch b/meta/packages/opensync/syncml-client-0.1/syncml-client-plugin-h.patch
new file mode 100644 (file)
index 0000000..c936445
--- /dev/null
@@ -0,0 +1,11 @@
+--- tmp/src/syncml-client.h.orig       2007-01-09 12:15:41.000000000 +0000
++++ tmp/src/syncml-client-plugin.h     2007-01-09 12:15:41.000000000 +0000
+@@ -20,7 +20,7 @@
+ #define  SYNCML_CLIENT_PLUGIN
+ #include <opensync/opensync.h>
+-#include <syncml-client.h>
++#include <syncml-client/syncml-client.h>
+ #include "SmcSyncSource.h"
+ #include "SmcConfig.h"
index 7a99236d901a6d91d3453dfbb97fab7ec645f3d3..95a4e339c77de36d35c1e826df7c094264f1b2ef 100644 (file)
@@ -1,8 +1,14 @@
-SRC_URI = "http://hem.bredband.net/miko22/${P}.tar.gz"
-
 LICENSE = "GPL"
 DEPENDS = "gtk+ curl gconf"
 HOMEPAGE = "http://hem.bredband.net/miko22/"
 DESCRIPTION = "Linux port of the Funambol C++ SyncML client connector." 
+PR="r1"
+
+SRC_URI = "http://hem.bredband.net/miko22/${P}.tar.gz       \
+          file://syncml-client-pc-in-cross.patch;patch=1 "
 
 inherit autotools pkgconfig
+
+do_stage() {
+       autotools_stage_all
+}