]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: use the exported LDDLFLAGS in generate_config_sh script
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 22 Nov 2012 15:22:10 +0000 (17:22 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Nov 2012 15:12:06 +0000 (15:12 +0000)
The perl shared libraries did not have RPATHs set and that made
autoreconf fail when using the SDK. The LDDLFLAGS environment variable
was already exported in the recipe but was not used when generating the
config.sh.

[YOCTO #3338]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl-5.14.2/generate-sh.patch
meta/recipes-devtools/perl/perl_5.14.2.bb

index 47f91c56d35225b6b43257dad6c6384920191512..27f6e691c0f982a22b49b4ba41af54a461055de4 100644 (file)
@@ -3,10 +3,10 @@ Upstream-Status:Inappropriate [embedded specific]
 Use the ld flags from the supplied configuration file. For sh we need the
 flags that specify to build PIC code so that the shared libraries work.
 
-Index: perl-5.8.8/Cross/generate_config_sh
+Index: perl-5.14.2/Cross/generate_config_sh
 ===================================================================
---- perl-5.8.8.orig/Cross/generate_config_sh   2003-09-05 18:31:08.000000000 +1000
-+++ perl-5.8.8/Cross/generate_config_sh        2007-05-30 09:12:50.000000000 +1000
+--- perl-5.14.2.orig/Cross/generate_config_sh  2010-12-30 04:07:14.000000000 +0200
++++ perl-5.14.2/Cross/generate_config_sh       2012-11-22 15:58:49.852852805 +0200
 @@ -19,10 +19,10 @@
  $callbacks->{'ar'} = [\&simple_process, ["AR", "arm-linux-ar"]];
  $callbacks->{'archname'} = [\&simple_process, ["SYS", "armv4l-linux"]];
@@ -22,7 +22,15 @@ Index: perl-5.8.8/Cross/generate_config_sh
  $callbacks->{'ccname'} = [\&simple_process, ["CC", "arm-linux-gcc"]];
  $callbacks->{'cpp'} = [\&simple_process, ["CCP", "arm-linux-cpp"]];
  $callbacks->{'cppflags'} = [\&simple_process, ["CCPFLAGS", "-fno-strict-aliasing"]];
-@@ -105,6 +105,23 @@
+@@ -30,6 +30,7 @@
+ $callbacks->{'cppstdin'} = [\&simple_process_append, ["CC", "arm-linux-gcc -E", "-E"]];
+ $callbacks->{'full_ar'} = [\&backtick, ["AR", "which $ENV{AR}", "/usr/local/arm/2.95.3/bin/arm-linux-ar"]];
+ $callbacks->{'ld'} = [\&simple_process, ["LD", "arm-linux-ld"]];
++$callbacks->{'lddlflags'} = [\&simple_process, ["LDDLFLAGS", ""]];
+ $callbacks->{'ldflags'} = [\&simple_process, ["LDFLAGS", ""]];
+ $callbacks->{'ldflags_uselargefiles'} = [\&simple_process, ["LDFLAGS", ""]];
+ $callbacks->{'myarchname'} = [\&simple_process, ["SYS", "armv4l-linux"]];
+@@ -105,6 +106,23 @@
  
  }
  
index bfc34d5caf600f28d0f3ae7055d24fe7bed13cbe..4dac5ceb8669bfd93954c2529dce8e9387d235cf 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db grep-native"
 DEPENDS += "gdbm zlib"
-PR = "r14"
+PR = "r15"
 
 # 5.10.1 has Module::Build built-in
 PROVIDES += "libmodule-build-perl"