]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr/apr-util: Add ptest dependency on libgcc
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 16 May 2019 11:46:03 +0000 (12:46 +0100)
committerArmin Kuster <akuster808@gmail.com>
Sun, 2 Jun 2019 17:25:22 +0000 (10:25 -0700)
Avoid:

libgcc_s.so.1 must be installed for pthread_cancel to work

when running the ptest without libgcc.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-support/apr/apr-util_1.6.1.bb
meta/recipes-support/apr/apr_1.6.5.bb

index 0c90f8d2527b0b9e1b600254aa1df5ba71628e0a..1f9fea25d87a671890d433de578660fae924eda6 100644 (file)
@@ -79,6 +79,7 @@ INSANE_SKIP_${PN} += "dev-so"
 inherit ptest
 
 RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-iso8859-1 glibc-gconv-iso8859-2 glibc-gconv-utf-7"
+RDEPENDS_${PN}-ptest += "libgcc"
 
 do_compile_ptest() {
        cd ${B}/test
index 432e4ed74473099b64f496cab32ead903e793917..79879ff25f0a76674741221b716aa7b1a0f4730c 100644 (file)
@@ -53,6 +53,8 @@ do_configure_prepend() {
 FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
 RDEPENDS_${PN}-dev += "bash"
 
+RDEPENDS_${PN}-ptest += "libgcc"
+
 #for some reason, build/libtool.m4 handled by buildconf still be overwritten
 #when autoconf, so handle it again.
 do_configure_append() {