]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: fix for non /usr/lib libdir case
authorYu Ke <ke.yu@intel.com>
Mon, 11 Jul 2011 07:23:21 +0000 (15:23 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Jul 2011 13:58:01 +0000 (14:58 +0100)
rpm default will use /usr/lib if the --with-path-lib is not specified.
this will not work in non /usr/lib libdir case.

so this patch add the --with-path-lib to fix this issue.

Signed-off-by: Yu Ke <ke.yu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.0.bb

index d0933456b858c15b643984c371385a39c885847a..9cfb3ab03b9e16ed5067c5960e28a2a4f9865c80 100644 (file)
@@ -45,7 +45,7 @@ LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 DEPENDS = "bzip2 zlib db openssl elfutils expat libpcre attr acl popt ${extrarpmdeps}"
 extrarpmdeps = "python perl"
 extrarpmdeps_virtclass-native = ""
-PR = "r18"
+PR = "r19"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...
@@ -162,6 +162,7 @@ EXTRA_OECONF = "--verbose \
                --enable-build-debug \
                --enable-maintainer-mode \
                --with-path-macros=${rpm_macros} \
+               --with-path-lib=${libdir}/rpm \
                --with-bugreport=http://bugzilla.yoctoproject.org"
 
 CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY"