]> code.ossystems Code Review - openembedded-core.git/commitdiff
xf86-video-intel: add recipe for 2.99.910, remove the git one
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Fri, 7 Mar 2014 14:33:05 +0000 (14:33 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 11 Mar 2014 15:06:11 +0000 (08:06 -0700)
Intel graphics stack releases >= 2013Q3 need
xf86-video-intel >= 2.99.902. However, keep the stable release around
too, in case people need it.

The git recipe is not really used. Remove, since it has missing
PACKAGECONFIG, license checksums and so on.

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/default-versions.inc
meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.910.bb [new file with mode: 0644]
meta/recipes-graphics/xorg-driver/xf86-video-intel_git.bb [deleted file]

index 53ec2e7caf3911d93d932021f25df9eef377b227..a9a931d772ca880cf9520dab012e3361409f919e 100644 (file)
@@ -9,3 +9,6 @@ PREFERRED_VERSION_python-native ?= "2.7.3"
 
 # Force the older version of liberation-fonts until we fix the fontforge issue
 PREFERRED_VERSION_liberation-fonts ?= "1.04"
+
+# Intel video stack 2013Q3 and newer need a version >=2.99.902
+PREFERRED_VERSION_xf86-video-intel ?= "2.99.910"
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.910.bb b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.910.bb
new file mode 100644 (file)
index 0000000..b74d174
--- /dev/null
@@ -0,0 +1,31 @@
+require xorg-driver-video.inc
+
+SUMMARY = "X.Org X server -- Intel integrated graphics chipsets driver"
+
+DESCRIPTION = "intel is an Xorg driver for Intel integrated graphics \
+chipsets. The driver supports depths 8, 15, 16 and 24. On some chipsets, \
+the driver supports hardware accelerated 3D via the Direct Rendering \
+Infrastructure (DRI)."
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e"
+
+DEPENDS += "virtual/libx11 drm libpciaccess pixman"
+
+SRC_URI += "file://compat-api-Map-changes-of-DamageUnregister-API-in-1..patch \
+           "
+
+PACKAGECONFIG ??= "sna udev ${@base_contains('DISTRO_FEATURES', 'opengl', 'dri', '', d)}"
+
+PACKAGECONFIG[dri] = "--enable-dri,--disable-dri,xf86driproto dri2proto"
+PACKAGECONFIG[sna] = "--enable-sna,--disable-sna"
+PACKAGECONFIG[uxa] = "--enable-uxa,--disable-uxa"
+PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
+PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc"
+
+# --enable-kms-only option is required by ROOTLESS_X
+EXTRA_OECONF += '${@base_conditional( "ROOTLESS_X", "1", " --enable-kms-only", "", d )}'
+
+COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
+SRC_URI[md5sum] = "a9a5c2c15766c06a024381efe0d724bb"
+SRC_URI[sha256sum] = "203d46064449da0e23a111418dfb189422ba96ea08707167c8dee463e2d745b1"
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel_git.bb b/meta/recipes-graphics/xorg-driver/xf86-video-intel_git.bb
deleted file mode 100644 (file)
index d4c7654..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-require xorg-driver-video.inc
-
-SUMMARY = "X.Org X server -- Intel integrated graphics chipsets driver"
-
-DESCRIPTION = "intel is an Xorg driver for Intel integrated graphics \
-chipsets. The driver supports depths 8, 15, 16 and 24. On some chipsets, \
-the driver supports hardware accelerated 3D via the Direct Rendering \
-Infrastructure (DRI)."
-
-DEPENDS += "virtual/libx11 drm dri2proto glproto \
-           virtual/libgl xineramaproto libpciaccess udev"
-
-SRCREV = "87ea531c5dc5b39809395b277c330854aaaaf019"
-PV = "2.10.0+git${SRCPV}"
-PR = "${INC_PR}.1"
-
-EXTRA_OECONF += "--disable-xvmc --enable-dri --disable-static"
-
-SRC_URI = "git://anongit.freedesktop.org/git/xorg/driver/xf86-video-intel"
-
-S = "${WORKDIR}/git"
-
-COMPATIBLE_HOST = '(i.86|x86_64).*-linux'