]> code.ossystems Code Review - openembedded-core.git/commitdiff
dtc: add PACKAGECONFIGs for tools and yaml
authorRoss Burton <ross@burtonini.com>
Fri, 12 Nov 2021 14:02:34 +0000 (14:02 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 13 Nov 2021 16:08:07 +0000 (16:08 +0000)
Leave yaml off by default.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/dtc/dtc_1.6.1.bb

index 44293cf4ffbce146673fec5be5a55b4d84b623dd..6365f73e10e6b05db06ace87fe50bbeaed1fdd5f 100644 (file)
@@ -3,7 +3,6 @@ HOMEPAGE = "https://devicetree.org/"
 DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
 SECTION = "bootloader"
 LICENSE = "GPLv2 | BSD-2-Clause"
-DEPENDS = "flex-native bison-native"
 
 LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://libfdt/libfdt.h;beginline=4;endline=7;md5=05bb357cfb75cae7d2b01d2ee8d76407"
@@ -19,9 +18,12 @@ inherit meson pkgconfig
 
 EXTRA_OEMESON = "-Dpython=disabled -Dvalgrind=disabled"
 
+PACKAGECONFIG ??= "tools"
+PACKAGECONFIG[tools] = "-Dtools=true,-Dtools=false,flex-native bison-native"
+PACKAGECONFIG[yaml] = "-Dyaml=enabled,-Dyaml=disabled,libyaml"
+
 PACKAGES =+ "${PN}-misc"
 FILES:${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff"
-
-RDEPENDS:${PN}-misc += "bash diffutils"
+RDEPENDS:${PN}-misc += "${@bb.utils.contains('PACKAGECONFIG', 'tools', 'bash diffutils', '', d)}"
 
 BBCLASSEXTEND = "native nativesdk"