]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot-mkimage-openmoko-native: stage mkimage instead of deploying - should fix linux...
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 6 Mar 2008 15:54:15 +0000 (15:54 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 6 Mar 2008 15:54:15 +0000 (15:54 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3970 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb

index d0d47d84d8f98683adad6a4434cfe69a0dbb704a..574cda19b13013aede5894acfd1fe91b9e2050cc 100644 (file)
@@ -1,6 +1,7 @@
 require uboot-openmoko_svn.bb
 
 PV = "1.2.0+git9912121f7ed804ea58fd62f3f230b5dcfc357d88svn2238"
+PR = "r1"
 
 SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git;tag=9912121f7ed804ea58fd62f3f230b5dcfc357d88 \
 file://uboot-machtypes.patch;patch=1 \
@@ -72,12 +73,11 @@ do_compile () {
         oe_runmake tools
 }
 
-do_deploy () {
+do_stage () {
         install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
         ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
 }
 
-do_deploy[dirs] = "${S}"
-addtask deploy before do_package after do_install
-
-
+do_deploy() {
+:
+}