]> code.ossystems Code Review - openembedded-core.git/commitdiff
libffi: Use proper compiler define for linux platform
authorKhem Raj <raj.khem@gmail.com>
Mon, 6 Apr 2015 17:36:43 +0000 (17:36 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 9 Apr 2015 18:48:03 +0000 (19:48 +0100)
Change-Id: I8253249a2e1c5e9ded0d028545f21cfdc093c3cd
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/libffi/libffi/0001-mips-Use-compiler-internal-define-for-linux.patch [new file with mode: 0644]
meta/recipes-gnome/libffi/libffi_3.2.1.bb

diff --git a/meta/recipes-gnome/libffi/libffi/0001-mips-Use-compiler-internal-define-for-linux.patch b/meta/recipes-gnome/libffi/libffi/0001-mips-Use-compiler-internal-define-for-linux.patch
new file mode 100644 (file)
index 0000000..db96e63
--- /dev/null
@@ -0,0 +1,32 @@
+From a5efaa96fd934eb245c234a5275fcf62698ef986 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 2 Apr 2015 21:38:03 -0700
+Subject: [PATCH] mips: Use compiler internal define for linux
+
+__linux__ is defined by compiler when building for
+linux platforms, lets use it
+
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/mips/ffitarget.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mips/ffitarget.h b/src/mips/ffitarget.h
+index 717d659..6faa358 100644
+--- a/src/mips/ffitarget.h
++++ b/src/mips/ffitarget.h
+@@ -32,7 +32,7 @@
+ #error "Please do not include ffitarget.h directly into your source.  Use ffi.h instead."
+ #endif
+-#ifdef linux
++#ifdef __linux__
+ # include <asm/sgidefs.h>
+ #elif defined(__rtems__)
+ /*
+-- 
+2.1.4
+
index 23028109cce1e895b0e835a14b27610c0766740c..fd916caf7ee6ff66f0bd33aefa8286f4ec416e47 100644 (file)
@@ -10,7 +10,9 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b"
 
 SRC_URI = "ftp://sourceware.org/pub/libffi/${BP}.tar.gz \
-           file://fix-libffi.la-location.patch"
+           file://fix-libffi.la-location.patch \
+          file://0001-mips-Use-compiler-internal-define-for-linux.patch \
+          "
 
 SRC_URI[md5sum] = "83b89587607e3eb65c70d361f13bab43"
 SRC_URI[sha256sum] = "d06ebb8e1d9a22d19e38d63fdb83954253f39bedc5d46232a05645685722ca37"