]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: Avoid installing test data into recipe-sysroot
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jan 2021 17:12:46 +0000 (17:12 +0000)
committerSteve Sakoman <steve@sakoman.com>
Fri, 29 Jan 2021 14:46:55 +0000 (04:46 -1000)
There are several thousand files in the test directory which we don't need.
Adding these for the native and target sysroots is a crazy amount of files
to be throwing around needlessly. Delete the files from the sysroot side
of things to tidy up the sysroots and improve performance.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit f6bced03011ad1663d68b0322a2f8aeb4d836646)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/python/python3_3.8.2.bb

index 9eddad4ad4a317c7270eb9deccfd4adcba3622b8..a86542e5477144f4a670448f4dadcdef8069df21 100644 (file)
@@ -360,3 +360,9 @@ RDEPENDS_${PN}-dev = ""
 
 RDEPENDS_${PN}-tests_append_class-target = " bash"
 RDEPENDS_${PN}-tests_append_class-nativesdk = " bash"
+
+# Python's tests contain large numbers of files we don't need in the recipe sysroots
+SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
+py3_sysroot_cleanup () {
+       rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
+}