]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: fix broken shell comparsion in do_install
authorHenning Heinold <henning@itconsulting-heinold.de>
Mon, 9 Jun 2014 21:21:28 +0000 (23:21 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Jul 2014 12:46:05 +0000 (13:46 +0100)
The patch was sponsored by sysmocom

Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index ef21b6c9c20b5feb7dba93f4f98c16c5b1a6c05b..9996f663cd0ea7685f6a9664e541b0b2623b77e9 100644 (file)
@@ -112,7 +112,7 @@ do_install() {
        unset CFLAGS
        oe_runmake DESTDIR=${D} install
        # we are checking for this make target to be compatible with older perf versions
-       if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then
+       if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0" ]; then
                oe_runmake DESTDIR=${D} install-python_ext
        fi
 }