]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcap: fix sstate for native package
authorOtavio Salvador <otavio@ossystems.com.br>
Wed, 2 Nov 2011 18:41:11 +0000 (18:41 +0000)
committerSaul Wold <sgw@linux.intel.com>
Tue, 8 Nov 2011 19:19:48 +0000 (11:19 -0800)
The 'lib' option needs to be given on target and native builds
otherwise it installs the binaries at ${libdir}64 when host is 64bit.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
meta/recipes-support/libcap/libcap.inc
meta/recipes-support/libcap/libcap_2.22.bb

index 350653071eab8ff9b7752702b8289ea134612559..184b58a3e0b5ffb179030ddd3705acba73d1eb14 100644 (file)
@@ -21,9 +21,18 @@ do_configure() {
        sed -e 's,BUILD_CFLAGS ?=,BUILD_CFLAGS := $(BUILD_CFLAGS),' -i Make.Rules
 }
 
-EXTRA_OEMAKE = "LIBATTR=yes PAM_CAP=${@base_contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} INDENT= SYSTEM_HEADERS=${STAGING_INCDIR} RAISE_SETFCAP=no"
-EXTRA_OEMAKE_virtclass-native = "LIBATTR=no PAM_CAP=no INDENT= "
-EXTRA_OEMAKE += " lib=${@os.path.basename('${libdir}')}"
+EXTRA_OEMAKE = " \
+  LIBATTR=yes \
+  PAM_CAP=${@base_contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} \
+  INDENT= SYSTEM_HEADERS=${STAGING_INCDIR} RAISE_SETFCAP=no \
+  lib=${@os.path.basename('${libdir}')} \
+"
+EXTRA_OEMAKE_virtclass-native = " \
+  LIBATTR=no \
+  PAM_CAP=no \
+  INDENT= \
+  lib=${@os.path.basename('${libdir}')} \
+"
 
 do_compile() {
        oe_runmake
index a31ba3fadd905f534684cf049f3bda5032742c02..dd63d9e742f5016232bdcdfb35888e3af99026e2 100644 (file)
@@ -1,6 +1,6 @@
 require libcap.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI[md5sum] = "ce64058bdb3f086ddbfca8ce6c919845"
 SRC_URI[sha256sum] = "73ebbd4877b5f69dd28b72098e510c5b318bc480f8201c4061ac98b78c04050f"