]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: fix metadata
authorQing He <qing.he@intel.com>
Fri, 2 Jul 2010 02:11:50 +0000 (10:11 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Fri, 2 Jul 2010 22:32:46 +0000 (15:32 -0700)
add bugtracker, clarify license

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/rpm/rpm_4.4.2.3.bb

index 6efa87bb00d011ae58a4116414491c5f541c2b60..6605650023b30bd163c906c98fd982fbc713a669 100644 (file)
@@ -1,6 +1,10 @@
 DESCRIPTION = "The RPM Package Manager."
 HOMEPAGE = "http://rpm.org/"
-LICENSE = "LGPL GPL"
+BUGTRACKER = "http://rpm.org/report"
+
+# library is covered under dual license of GPL | LGPL
+LICENSE = "(LGPLv2+ | GPLv2+) & GPLv2+"
+
 DEPENDS = "zlib beecrypt file popt python"
 PR = "r16"
 
@@ -13,10 +17,10 @@ SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
           file://extcond.patch;patch=1;pnum=0 \
           file://disabledwarf.patch;patch=1"
 
-inherit autotools gettext
-
 S = "${WORKDIR}/rpm-${PV}"
 
+inherit autotools gettext
+
 acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
 
 EXTRA_OECONF = "--with-python=$PYTHONVER \