]> code.ossystems Code Review - openembedded-core.git/commitdiff
xkeyboard-config: add keymaps for X11
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 22 Sep 2008 13:59:21 +0000 (13:59 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 22 Sep 2008 13:59:21 +0000 (13:59 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5211 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb [new file with mode: 0644]

diff --git a/meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb b/meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb
new file mode 100644 (file)
index 0000000..c3bc53f
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Common X11 Keyboard layouts"
+LICENSE = "MIT"
+DEPENDS = "intltool xkbcomp-native"
+RDEPENDS = "xkbcomp"
+PR = "r1"
+
+SRC_URI = "http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-${PV}.tar.bz2"
+
+inherit autotools
+
+do_stage() {
+        autotools_stage_all
+}
+
+do_install_append () {
+    install -d ${D}/usr/share/X11/xkb/compiled
+}
+
+FILES_${PN} += "${datadir}/X11/xkb"