]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: add tk-lib as runtime dependency for python-tkinter
authorYi Zhao <yi.zhao@windriver.com>
Thu, 19 Sep 2019 07:44:11 +0000 (15:44 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 Oct 2019 09:07:18 +0000 (10:07 +0100)
Fixes:
ERROR: python-2.7.16-r0 do_package_qa: QA Issue:
/usr/lib/python2.7/lib-dynload/_tkinter.so contained in package
python-tkinter requires libtk8.6.so, but no providers found in
RDEPENDS_python-tkinter? [file-rdeps]

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3_3.7.4.bb
meta/recipes-devtools/python/python_2.7.16.bb

index 14119c33f9466c8faa2491e8fdf657ca2dec4c07..8693c446c253758fa4b9c7612abcb1072b6cb6ae 100644 (file)
@@ -321,6 +321,6 @@ FILES_${PN}-man = "${datadir}/man"
 
 RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed"
 RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
-RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk', '', d)}"
+RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
 RDEPENDS_${PN}-dev = ""
 
index c093f84a35b088aee2a7d4aa386ce1193d552b87..5b856a50977d0fe6dbed4b6cc1a394f53b62d47b 100644 (file)
@@ -173,7 +173,7 @@ RDEPENDS_${PN}-modules += "${PN}-misc"
 
 # ptest
 RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip tzdata-europe coreutils sed"
-RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk', '', d)}"
+RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
 # catch manpage
 PACKAGES += "${PN}-man"
 FILES_${PN}-man = "${datadir}/man"