]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers: Fix file conflict -- ..install.cmd
authorMark Hatle <mark.hatle@windriver.com>
Tue, 26 Jul 2011 18:00:27 +0000 (13:00 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 14:39:17 +0000 (15:39 +0100)
The ..install.cmd conflicts between various configure runs.

This isn't used anywhere, so remove it to avoid the conflict.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.37.2.bb
meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb

index a9b041fb08faf8254a57c7be3a3066bc8da50167..1c709cbc23a335736afa19a44464b6ef9fefa170 100644 (file)
@@ -10,7 +10,7 @@ RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
 RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
 SRCREV = "69cfbdf9f1ff461a75e5b77d6d7ba35e97db4cc3"
 PV = "2.6.37+git-${SRCPV}"
-PR = "r3"
+PR = "r4"
 
 SRCREV_FORMAT = "meta_machine"
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
@@ -47,6 +47,9 @@ do_compile () {
 do_install() {
        set_arch
        oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+
+        # The ..install.cmd conflicts between various configure runs
+        find ${D}${includedir} -name ..install.cmd | xargs rm -f
 }
 
 BBCLASSEXTEND = "nativesdk"
index 51c4926429c79d0098b557d027ab8502e2738d3a..55d752798a45d06e1cc71ae74fddc9c5a1b1d3c4 100644 (file)
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS += "unifdef-native"
-PR = "r1"
+PR = "r2"
 
 SRC_URI += " file://connector-msg-size-fix.patch"
 
@@ -43,6 +43,9 @@ do_install() {
        oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
        # Kernel should not be exporting this header
        rm -f ${D}${exec_prefix}/include/scsi/scsi.h
+
+       # The ..install.cmd conflicts between various configure runs
+       find ${D}${includedir} -name ..install.cmd | xargs rm -f
 }
 
 BBCLASSEXTEND = "nativesdk"
index 65c19ecea668e9a34844a38bfd8d436d23900dfd..14f5e8a1ae84c7a26fa52bf22f6faf2af27ea1a4 100644 (file)
@@ -9,6 +9,8 @@ SRC_URI[sha256sum] = "584d17f2a3ee18a9501d7ff36907639e538cfdba4529978b8550c461d4
 
 S = "${WORKDIR}/linux-${PV}"
 
+PR = "r2"
+
 set_arch() {
        case ${TARGET_ARCH} in
                alpha*)   ARCH=alpha ;;
@@ -44,6 +46,9 @@ do_install() {
        oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
        # Kernel should not be exporting this header
        rm -f ${D}${exec_prefix}/include/scsi/scsi.h
+
+        # The ..install.cmd conflicts between various configure runs
+        find ${D}${includedir} -name ..install.cmd | xargs rm -f
 }
 
 BBCLASSEXTEND = "nativesdk"