]> code.ossystems Code Review - openembedded-core.git/commitdiff
cdrtools: recipe and patch cleanup
authorScott Garman <scott.a.garman@intel.com>
Mon, 25 Apr 2011 19:48:47 +0000 (12:48 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 28 Apr 2011 08:52:28 +0000 (09:52 +0100)
* Recipe cleanup, added missing metadata fields and fixed
  whitespace issues
* Added Upstream-Status to patches
* Confirmed that CVE-2003-0655 does not apply to this recipe
  as rscsi is not packaged

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/cdrtools/cdrtools-native/glibc-conflict-rename.patch
meta/recipes-devtools/cdrtools/cdrtools-native/no_usr_src.patch
meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb

index 0b9b892aa2fb1d93825896cee1919e27bd1f69ae..2fd569656104c8ea05efc7572766553982a1c9e2 100644 (file)
@@ -1,3 +1,11 @@
+This patch fixes collisions between locally defined functions
+and glibc's fexecve() and getline() functions.
+
+Upstream-Status: Inappropriate [Other]
+Upstream no longer maintains a GPL version of this utility.
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
 Index: cdrtools-2.01/include/schily.h
 ===================================================================
 --- cdrtools-2.01.orig/include/schily.h        2009-06-18 11:30:45.000000000 +0100
index 0318d31a6d4408e1496e6ab251bdefbbc8343a19..82e57d182d8a2573eeb547a92f2032efbc95b27f 100644 (file)
@@ -1,3 +1,10 @@
+Remove hard-coded references to /usr/src/linux/include to avoid
+host contamination.
+
+Upstream-Status: [Other (build-system specific)]
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
 Index: cdrtools-2.01/DEFAULTS/Defaults.gnu
 ===================================================================
 --- cdrtools-2.01.orig/DEFAULTS/Defaults.gnu   2008-09-22 12:42:12.000000000 +0100
index 769e5e258ab928621153fe281191ff52a3436e4a..aba6a455b0c0baf4ff70d8e279267a988432b705 100644 (file)
@@ -1,21 +1,25 @@
 # cdrtools-native OE build file
 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
 # Released under the MIT license (see packages/COPYING)
-
-LICENSE="GPL"
-DESCRIPTION="A set of tools for CD recording, including cdrecord"
-HOMEPAGE="http://cdrecord.berlios.de/old/private/cdrecord.html"
+SUMMARY = "A set of tools for CD recording, including cdrecord"
+DESCRIPTION = "A set of tools for CD recording, including cdrecord"
+HOMEPAGE = "http://cdrecord.berlios.de/private/cdrecord.html"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 PR = "r2"
 
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+SRC_URI = "ftp://ftp.berlios.de/pub/cdrecord/cdrtools-${PV}.tar.bz2 \
+           file://no_usr_src.patch \
+           file://glibc-conflict-rename.patch"
 
-SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/cdrtools-${PV}.tar.bz2 \
-         file://no_usr_src.patch;patch=1 \
-         file://glibc-conflict-rename.patch;patch=1"
+SRC_URI[md5sum] = "d44a81460e97ae02931c31188fe8d3fd"
+SRC_URI[sha256sum] = "728b6175069a77c4d7d92ae60108cbda81fbbf7bc7aa02e25153ccf2092f6c22"
 
 inherit native
 
-STAGE_TEMP="${WORKDIR}/image-temp"
+STAGE_TEMP = "${WORKDIR}/image-temp"
 
 do_install() {
        install -d ${STAGE_TEMP}