]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-collateral: Simplify source files
authorPaul Barker <paul@paulbarker.me.uk>
Fri, 19 Dec 2014 17:35:29 +0000 (17:35 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Feb 2015 14:53:44 +0000 (14:53 +0000)
Instead of having the source files 'opkg.conf.comments', 'dest' and 'src', we
simply have one 'opkg.conf' file containing all the necessary configuration.

This does mean that replacing 'src' in a bbappend to define distro-specific
package feeds is no longer supported, but these feed configurations should be
packaged separately from the rest of the opkg configuration anyway so that
things can be updated independently. The best recipe to use for managing feed
configs is currently distro-feed-config in the meta-oe layer.

Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
meta/recipes-devtools/opkg/opkg-collateral.bb
meta/recipes-devtools/opkg/opkg-collateral/dest [deleted file]
meta/recipes-devtools/opkg/opkg-collateral/opkg.conf [moved from meta/recipes-devtools/opkg/opkg-collateral/opkg.conf.comments with 92% similarity]
meta/recipes-devtools/opkg/opkg-collateral/src [deleted file]

index 0cf6b8be403cc87befcaf77000fb219bc5506495..f080dfc3ab1839a3184385cc8e7b2afe501eb687 100644 (file)
@@ -4,17 +4,12 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 PR = "r2"
 
-SRC_URI = "file://opkg.conf.comments \
-          file://dest \
-          file://src "
+SRC_URI = "file://opkg.conf"
 
 S = "${WORKDIR}"
 
 OPKGLIBDIR = "${localstatedir}/lib"
 do_compile () {
-       cat ${WORKDIR}/opkg.conf.comments >${WORKDIR}/opkg.conf
-       cat ${WORKDIR}/src      >>${WORKDIR}/opkg.conf
-       cat ${WORKDIR}/dest     >>${WORKDIR}/opkg.conf
        echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
 }
 
diff --git a/meta/recipes-devtools/opkg/opkg-collateral/dest b/meta/recipes-devtools/opkg/opkg-collateral/dest
deleted file mode 100644 (file)
index 088ca40..0000000
+++ /dev/null
@@ -1 +0,0 @@
-dest root /
similarity index 92%
rename from meta/recipes-devtools/opkg/opkg-collateral/opkg.conf.comments
rename to meta/recipes-devtools/opkg/opkg-collateral/opkg.conf
index e1fdada9b5e6cae663aafc2668f156b0c07163d7..c2e9e92f95bbf231e1ec44e249f7495917203ebf 100644 (file)
@@ -24,3 +24,5 @@
 # Offline mode (for use in constructing flash images offline)
 #option offline_root target
 
+# Default destination for installed packages
+dest root /
diff --git a/meta/recipes-devtools/opkg/opkg-collateral/src b/meta/recipes-devtools/opkg/opkg-collateral/src
deleted file mode 100644 (file)
index e69de29..0000000