]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: add nativesdk-libnss-nis
authorChen Qi <Qi.Chen@windriver.com>
Fri, 25 May 2018 02:54:46 +0000 (10:54 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jul 2018 21:54:56 +0000 (22:54 +0100)
Recent glibc change removed libnss-nis module from glibc and a new
recipe libnss-nis.bb was added.

After this change, we need to make sure nativesdk-libnss-nis is also
included in buildtools-tarball, otherwise, we may encounter the following
error when using 'tar' command from buildtools-tarball.

  tar: relocation error: /lib/x86_64-linux-gnu/libnss_nis.so.2: \
       symbol _nsl_default_nss version GLIBC_PRIVATE not defined \
       in file libnsl.so.1 with link time reference

This error occured on my ubuntu16.04 host with 'nis' configured in
/etc/nssswitch.conf.

So add nativesdk-libnss-nis to buildtools-tarball to fix this problem.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/buildtools-tarball.bb

index d98a9c901ce882d80906d17074ae179242397959..377733f40ea92b9410491a3d8025136c2df27562 100644 (file)
@@ -21,6 +21,7 @@ TOOLCHAIN_HOST_TASK ?= "\
     nativesdk-wget \
     nativesdk-ca-certificates \
     nativesdk-texinfo \
+    nativesdk-libnss-nis \
     "
 
 MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"