]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-lsb: enforce pam as a needed distro feature
authorCristian Iorga <cristian.iorga@intel.com>
Mon, 31 Mar 2014 09:51:21 +0000 (12:51 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Apr 2014 10:56:31 +0000 (11:56 +0100)
core-image-lsb only gave a warning:
"WARNING: Building libpam but 'pam' isn't in DISTRO_FEATURES,
PAM won't work correctly"
when the proper DISTRO was not set for it.
default choice would be DISTRO = "poky-lsb",
but not necessarily, depending on each custom distro.

This fix will enforce the proper usage of pam
as a distro feature for core-image-lsb by giving
an error instead of just a warning.

Fixes [YOCTO #6073]

Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/images/core-image-lsb.bb

index ed316a64e7bff611ae2d4698c6f8748abafdaaee..ab61c6e6dfc4f988ef0006a70d27a37933d1d395 100644 (file)
@@ -9,4 +9,6 @@ IMAGE_INSTALL = "\
     packagegroup-core-lsb \
     "
 
-inherit core-image
+inherit core-image distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "pam"