]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: stage libblkid
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 30 Jan 2008 21:19:51 +0000 (21:19 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 30 Jan 2008 21:19:51 +0000 (21:19 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3640 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/e2fsprogs/e2fsprogs_1.38.bb

index ddfcd6139af3205ad13fe4bfea8416a92d7ace34..e98006f826ec6afeb33e78895d975da4713d04bb 100644 (file)
@@ -1,6 +1,6 @@
 require e2fsprogs.inc
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI += "file://no-hardlinks.patch;patch=1"
 S = "${WORKDIR}/e2fsprogs-${PV}"
@@ -20,6 +20,7 @@ ext2fsheaders = "ext2_ext_attr.h bitops.h ext2_err.h \
 e2pheaders = "e2p.h"
 
 do_stage () {
+       oe_libinstall -a -C lib libblkid ${STAGING_LIBDIR}/
        oe_libinstall -a -C lib libe2p ${STAGING_LIBDIR}/
        oe_libinstall -a -C lib libext2fs ${STAGING_LIBDIR}/
        install -d ${STAGING_INCDIR}/e2p
@@ -30,6 +31,10 @@ do_stage () {
        for h in ${ext2fsheaders}; do
                install -m 0644 lib/ext2fs/$h ${STAGING_INCDIR}/ext2fs/ || die "failed to install $h"
        done
+       install -d ${STAGING_INCDIR}/blkid
+       for h in blkid.h blkid_types.h; do
+               install -m 0644 lib/blkid/$h ${STAGING_INCDIR}/blkid/ || die "failed to install $h"
+       done
 }
 
 # blkid used to be part of e2fsprogs but is useful outside, add it