]> code.ossystems Code Review - openembedded-core.git/commitdiff
bind: clean host path in isc-config.sh
authorShiqun Lin <Shiqun.Lin@windriver.com>
Tue, 21 Oct 2014 08:12:51 +0000 (04:12 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Dec 2014 10:17:28 +0000 (10:17 +0000)
* /usr/bin/isc-config.sh
* /usr/bin/bind9-config - hardlink to isc-config.sh

(From OE-Core rev: c2332d304a2c872e97653c980b090efa2181123b)

Signed-off-by: Shiqun Lin <Shiqun.Lin@windriver.com>
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-connectivity/bind/bind_9.9.5.bb

index 73f386e6f1cf96be9e199685d1679325459cadf4..635d27732bb184413c3a6e29faea64c8c9870586 100644 (file)
@@ -51,6 +51,13 @@ FILES_${PN}-utils = "${bindir}/host ${bindir}/dig"
 FILES_${PN}-dev += "${bindir}/isc-config.h"
 FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
 
+do_install_prepend() {
+       # clean host path in isc-config.sh before the hardlink created
+       # by "make install":
+       #   bind9-config -> isc-config.sh
+       sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${S}/isc-config.sh
+}
+
 do_install_append() {
        rm "${D}${bindir}/nslookup"
        rm "${D}${mandir}/man1/nslookup.1"