]> code.ossystems Code Review - openembedded-core.git/commitdiff
initramfs-live-install*: fix the "install" boot option
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 15 Apr 2013 18:33:46 +0000 (11:33 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 16 Apr 2013 10:39:32 +0000 (11:39 +0100)
The install boot option was giving the following error when one tried to
install the live image on a  permanent storage of a BSP.

cat: write error Invalid argument
Installation image failed
sh: can't access tty: job control turned off

Further digging into the issue, found out that the install script was trying
to do this:
 cat /proc/mounts > /etc/mtab

And in the base-files recipe the /etc/mtab is made soft link to /proc/mounts.
So the cat command was failing to write on /etc/mtab. As the contents of
the /proc/mounts is already reflected in the /etc/mtab file due to the
symlink-ing, there is no need for this step to recreate /etc/mtab in the
install script. So just removing this unnecessary step, which solves the
install issue of the live images.

Fixes this bug:
[YOCTO #4229]

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initrdscripts/files/init-install-efi.sh
meta/recipes-core/initrdscripts/files/init-install.sh
meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb
meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb

index 23228c92c4823435b820b35696b9acfc32a487b8..9f7a9e7c61b5985cd0feb23e37f3e59c1bf36eb0 100644 (file)
@@ -66,7 +66,6 @@ rm -f /etc/udev/scripts/mount*
 umount /dev/${device}* 2> /dev/null || /bin/true
 
 mkdir -p /tmp
-cat /proc/mounts > /etc/mtab
 
 disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//")
 
index d2a0db3183c21fbe2f4d4ef6f554d6410a968517..2ecd333f927bab0227e89aa1b15033c6d527a3cc 100644 (file)
@@ -78,7 +78,6 @@ if [ ! -b /dev/loop0 ] ; then
 fi
 
 mkdir -p /tmp
-cat /proc/mounts > /etc/mtab
 
 disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//")
 
index 8ad47d476b6e8fe038197a47bf038a79a747ff6f..264931f9a3360217b96a98eb2e88d7f6ff995652 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 SRC_URI = "file://init-install-efi.sh"
 
-PR = "r0"
+PR = "r1"
 
 RDEPENDS_${PN} = "parted e2fsprogs-mke2fs dosfstools"
 
index 0f80f0e28ab3e157f1809c947904438df7a9c9da..3a8836d5b926cf08dd18d3c0ef7d2e191d333c09 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 SRC_URI = "file://init-install.sh"
 
-PR = "r8"
+PR = "r9"
 
 RDEPENDS_${PN} = "grub parted e2fsprogs-mke2fs"