]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: Fix build with eglibc 2.17
authorKhem Raj <raj.khem@gmail.com>
Sat, 5 Jan 2013 03:19:22 +0000 (19:19 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Jan 2013 23:42:36 +0000 (23:42 +0000)
Link with librt to get definitions of mq_* functions
Fixes errors like below

 /home/kraj/work/angstrom/sources/openembedded-core/build/tmp-eglibc/work/armv5te-oe-linux-gnueabi/udev/182-r3/udev-182/src/sd-daemon.c:394:
undefined reference to `mq_getattr'
| collect2: error: ld returned 1 exit status

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/udev/udev.inc
meta/recipes-core/udev/udev_182.bb

index 4705b9b7cd44e8bdce6d4495c44dfcb71bc01091..9f60b17567316bd79d2e74c24a24cb28c9ea100d 100644 (file)
@@ -9,7 +9,8 @@ LICENSE_libgudev = "LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://src/COPYING;md5=17c4e5fb495e6707ac92a3864926f979 \
                     file://src/gudev/COPYING;md5=fb494485a7d0505308cb68e4997cc266"
-                    
+
+LDFLAGS += "-lrt"
 
 DEPENDS = "acl glib-2.0 libusb usbutils pciutils gperf-native libxslt-native util-linux"
 RPROVIDES_${PN} = "hotplug"
index 0ae9f8c6b6c7cb0b47317e514f3a573772f2ec81..cf0f126b928530aae2801ac10aa51c1150c831ce 100644 (file)
@@ -1,6 +1,6 @@
 include udev.inc
 
-PR = "r3"
+PR = "r4"
 
 # module-init-tools from kmod_git will provide libkmod runtime
 DEPENDS += "module-init-tools"