]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxsettings-client: fix metadata and add MIT-style-license
authorDexuan Cui <dexuan.cui@intel.com>
Thu, 10 Jun 2010 13:27:11 +0000 (21:27 +0800)
committerJoshua Lock <josh@linux.intel.com>
Thu, 17 Jun 2010 22:13:24 +0000 (23:13 +0100)
One tricky issue for license part. This package doesn't ship with its own COPYING file and autotools will install a GPLv2 one instead of the actual MIT-style license here. So create a MIT-style license on the fly to reflect the fact.

Use new patch parameters.

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
meta/packages/libxsettings-client/files/MIT-style-license [new file with mode: 0644]
meta/packages/libxsettings-client/libxsettings-client_0.10.bb

diff --git a/meta/packages/libxsettings-client/files/MIT-style-license b/meta/packages/libxsettings-client/files/MIT-style-license
new file mode 100644 (file)
index 0000000..628de98
--- /dev/null
@@ -0,0 +1,22 @@
+/*
+ * Copyright © 2001 Red Hat, Inc.
+ *
+ * Permission to use, copy, modify, distribute, and sell this software and its
+ * documentation for any purpose is hereby granted without fee, provided that
+ * the above copyright notice appear in all copies and that both that
+ * copyright notice and this permission notice appear in supporting
+ * documentation, and that the name of Red Hat not be used in advertising or
+ * publicity pertaining to distribution of the software without specific,
+ * written prior permission.  Red Hat makes no representations about the
+ * suitability of this software for any purpose.  It is provided "as is"
+ * without express or implied warranty.
+ *
+ * RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL RED HAT
+ * BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION
+ * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN 
+ * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ * Author:  Owen Taylor, Red Hat, Inc.
+ */
index eba2df18ba1410c9b452e129e9ac969a6fe67eff..ecd6d181eb6d63430b157d0eda9d420d6631ed41 100644 (file)
@@ -1,16 +1,30 @@
 DESCRIPTION = "Common code for XSETTINGS"
+HOMEPAGE = "http://matchbox-project.org/sources/optional-dependencies/"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
 SECTION = "x/libs"
-LICENSE = "BSD-X"
+LICENSE = "MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+                    file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+                    file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
 PRIORITY = "optional"
 DEPENDS = "virtual/libx11"
 
-PR = "r2"
+PR = "r3"
 
 headers = "xsettings-common.h xsettings-client.h"
 
 SRC_URI = "http://projects.o-hand.com/matchbox/sources/optional-dependencies/Xsettings-client-0.10.tar.gz \
-        file://link-x11.patch;patch=1"
+        file://MIT-style-license \
+        file://link-x11.patch;apply=yes"
 
 S = "${WORKDIR}/Xsettings-client-0.10"
 
 inherit autotools gettext
+
+do_configure_prepend() {
+    # This package doesn't ship with its own COPYING file and
+    # autotools will install a GPLv2 one instead of the actual MIT-style license here.
+    # Add the correct license here to avoid confusion.
+    cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
+}
+