]> code.ossystems Code Review - openembedded-core.git/commitdiff
Check /proc/cmdline for 'x11=false' to disable X server startup
authorMatthew Allum <mallum@openedhand.com>
Sun, 3 Sep 2006 14:26:12 +0000 (14:26 +0000)
committerMatthew Allum <mallum@openedhand.com>
Sun, 3 Sep 2006 14:26:12 +0000 (14:26 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@695 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xserver-kdrive-common/xserver-nodm-init.bb
meta/packages/xserver-kdrive-common/xserver-nodm-init/xserver-nodm

index d1ed98dfaf28ed29c04658594cc0b24aa727d3fb..cea9f0cb28c8047ba12643940ff694d853d574e2 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
 LICENSE = "GPL"
 SECTION = "x11"
 PRIORITY = "optional"
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "file://xserver-nodm"
 S = ${WORKDIR}
index be405bc008e639fe25e493e3487c9a699d1a165b..a56edaa15b3f1c98a4a43e98ba6709eca3b8751d 100755 (executable)
@@ -8,6 +8,15 @@ killproc() {            # kill the named process(es)
         [ "$pid" != "" ] && kill $pid
 }
 
+for x in $(cat /proc/cmdline); do
+        case $x in
+        x11=false)
+               echo "X Server disabled" 
+               exit 0;
+                ;;
+        esac
+done
+
 case "$1" in
   start)
     # We don't want this script to block the rest of the boot process