]> code.ossystems Code Review - openembedded-core.git/commitdiff
libx11/diet-x11: Fix /usr/include problem for keysymdef.h
authorRichard Purdie <richard@openedhand.com>
Wed, 2 Jan 2008 15:15:36 +0000 (15:15 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 2 Jan 2008 15:15:36 +0000 (15:15 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3398 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xorg-lib/diet-x11/include_fix.patch [new file with mode: 0644]
meta/packages/xorg-lib/diet-x11_1.1.2.bb
meta/packages/xorg-lib/libx11_1.1.2.bb

diff --git a/meta/packages/xorg-lib/diet-x11/include_fix.patch b/meta/packages/xorg-lib/diet-x11/include_fix.patch
new file mode 100644 (file)
index 0000000..5653088
--- /dev/null
@@ -0,0 +1,62 @@
+---
+ configure.ac |   44 ++++++++++++++++++++++++--------------------
+ 1 file changed, 24 insertions(+), 20 deletions(-)
+
+Index: libX11-1.1.2/configure.ac
+===================================================================
+--- libX11-1.1.2.orig/configure.ac     2008-01-02 15:30:47.000000000 +0000
++++ libX11-1.1.2/configure.ac  2008-01-02 15:47:25.000000000 +0000
+@@ -207,29 +207,33 @@ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL,
+ #
+ KEYSYMDEF=""
+ AC_MSG_CHECKING([keysymdef.h])
+-for flag in $XPROTO_CFLAGS -I/usr/include; do
+-      case "$KEYSYMDEF" in
+-      "")
+-              case "$flag" in
+-              *-I*)
+-                      dir=`echo "$flag" | sed 's/ *-I//'`
+-                      file="$dir/X11/keysymdef.h"
+-                      if test -f "$file"; then
+-                              KEYSYMDEF="$file"
+-                      fi
++AC_ARG_WITH(keysymdef,
++      AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),  
++      KEYSYMDEF=$withval, KEYSYMDEF="")
++
++if test x$KEYSYMDEF = x; then
++      for flag in $XPROTO_CFLAGS -I/usr/include; do
++              case "$KEYSYMDEF" in
++              "")
++                      case "$flag" in
++                      *-I*)
++                              dir=`echo "$flag" | sed 's/ *-I//'`
++                              file="$dir/X11/keysymdef.h"
++                              if test -f "$file"; then
++                                      KEYSYMDEF="$file"
++                              fi
++                              ;;
++                      esac
+                       ;;
+               esac
+-              ;;
+-      esac
+-done
+-case "$KEYSYMDEF" in
+-"")
+-      AC_MSG_ERROR([Cannot find keysymdef.h])
+-      ;;
+-*)
++      done
++fi
++
++if test -f "$KEYSYMDEF"; then
+       AC_MSG_RESULT([$KEYSYMDEF])
+-        ;;
+-esac
++else
++      AC_MSG_ERROR([Cannot find keysymdef.h])
++fi
+ AC_SUBST(KEYSYMDEF)
+ AC_ARG_ENABLE(udc,
index f032987b88b175f977f217dcdc1137bb73243c69..9f1e877ab8280e55717dd95e900869e8c37ecf61 100644 (file)
@@ -1,8 +1,8 @@
 require libx11_${PV}.bb
 
 SRC_URI += "file://X18NCMSstubs.diff;patch=1 \
-           file://fix-disable-xlocale.diff;patch=1 \
+            file://fix-disable-xlocale.diff;patch=1 \
             file://fix-utf8-wrong-define.patch;patch=1"
 
-EXTRA_OECONF += "--disable-udc --disable-xcms --disable-xlocale --disable-xkb"
+EXTRA_OECONF += "--disable-udc --disable-xcms --disable-xlocale --disable-xkb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
 CFLAGS += "-D_GNU_SOURCE"
index 93ad71f4664a6171cf0b34c3000fe71f6b52f143..a4400ae88e67f63a709a3e90a93d7379af1c0e79 100644 (file)
@@ -5,12 +5,12 @@ DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \
             libxdmcp xf86bigfontproto kbproto inputproto"
 PROVIDES = "virtual/libx11"
 PE = "1"
-PR = "r2"
+PR = "r3"
 
 XORG_PN = "libX11"
 
-SRC_URI += "file://x11_disable_makekeys.patch;patch=1"
+SRC_URI += "file://x11_disable_makekeys.patch;patch=1 \
+            file://include_fix.patch;patch=1" 
 
 EXTRA_OECONF += "--without-xcb"