]> code.ossystems Code Review - openembedded-core.git/commitdiff
pciutils: added 2.2.4 from OE
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 29 Jun 2007 07:34:11 +0000 (07:34 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 29 Jun 2007 07:34:11 +0000 (07:34 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2054 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pciutils/pciutils-2.2.4/configure-uclibc.patch [new file with mode: 0644]
meta/packages/pciutils/pciutils-2.2.4/configure.patch [new file with mode: 0644]
meta/packages/pciutils/pciutils-2.2.4/pcimodules-pciutils.diff [new file with mode: 0644]
meta/packages/pciutils/pciutils_2.2.4.bb [new file with mode: 0644]

diff --git a/meta/packages/pciutils/pciutils-2.2.4/configure-uclibc.patch b/meta/packages/pciutils/pciutils-2.2.4/configure-uclibc.patch
new file mode 100644 (file)
index 0000000..bfde28c
--- /dev/null
@@ -0,0 +1,21 @@
+Index: pciutils-2.2.4/lib/configure
+===================================================================
+--- pciutils-2.2.4.orig/lib/configure  2007-05-16 23:37:38.000000000 +0200
++++ pciutils-2.2.4/lib/configure       2007-05-17 16:35:24.000000000 +0200
+@@ -39,6 +39,16 @@
+       sys=linux
+ fi
++if [ "$host" = "linux--uclibc" ]
++then
++      sys=linux
++fi
++
++if [ "$host" = "linux--uclibcgnueabi" ]
++then
++      sys=linux
++fi
++
+ c=config.h
+ m=config.mk
+ echo >$c "#define PCI_ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"
diff --git a/meta/packages/pciutils/pciutils-2.2.4/configure.patch b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
new file mode 100644 (file)
index 0000000..78d113c
--- /dev/null
@@ -0,0 +1,40 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: pciutils-2.2.4/lib/configure
+===================================================================
+--- pciutils-2.2.4.orig/lib/configure  2006-09-09 13:06:10.000000000 +0200
++++ pciutils-2.2.4/lib/configure       2006-10-31 11:52:13.000000000 +0100
+@@ -12,15 +12,15 @@
+ echo_n "Configuring libpci for your system..."
+ idsdir=${1:-/usr/share}
+ version=${2:-0.0}
+-sys=`uname -s`
+-rel=`uname -r`
++sys=${3:-`uname -s`}
++rel=${4:-`uname -r`}
+ if [ "$sys" = "AIX" -a -x /usr/bin/oslevel -a -x /usr/sbin/lsattr ]
+ then
+       rel=`/usr/bin/oslevel`
+       proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
+       cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
+ else
+-      cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`
++      cpu=${5:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`}
+ fi
+ if [ "$sys" = "GNU/kFreeBSD" ]
+ then
+@@ -34,6 +34,11 @@
+ echo " $host $rel"
+ zlib=$5
++if [ "$host" = "linux--gnueabi" ]
++then
++      sys=linux
++fi
++
+ c=config.h
+ m=config.mk
+ echo >$c "#define PCI_ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"
diff --git a/meta/packages/pciutils/pciutils-2.2.4/pcimodules-pciutils.diff b/meta/packages/pciutils/pciutils-2.2.4/pcimodules-pciutils.diff
new file mode 100644 (file)
index 0000000..a2f3621
--- /dev/null
@@ -0,0 +1,349 @@
+Index: pciutils-2.2.4/Makefile
+===================================================================
+--- pciutils-2.2.4.orig/Makefile       2006-09-09 14:57:03.000000000 +0200
++++ pciutils-2.2.4/Makefile    2006-10-31 10:59:48.000000000 +0100
+@@ -24,7 +24,7 @@
+ export
+-all: $(PCILIB) lspci setpci lspci.8 setpci.8 update-pciids update-pciids.8 $(PCI_IDS)
++all: $(PCILIB) lspci setpci lspci.8 setpci.8 update-pciids update-pciids.8 $(PCI_IDS) pcimodules pcimodules.8
+ $(PCILIB): $(PCIINC) force
+       $(MAKE) -C lib all
+@@ -34,9 +34,11 @@
+ lib/config.h lib/config.mk:
+       cd lib && ./configure "$(IDSDIR)" "$(VERSION)" "$(HOST)" "$(RELEASE)" "$(ZLIB)"
++pcimodules: pcimodules.o common.o $(PCILIB)
+ lspci: lspci.o common.o $(PCILIB)
+ setpci: setpci.o common.o $(PCILIB)
++pcimodules.o: pcimodules.c pciutils.h
+ lspci.o: lspci.c pciutils.h $(PCIINC)
+ setpci.o: setpci.c pciutils.h $(PCIINC)
+ common.o: common.c pciutils.h $(PCIINC)
+@@ -58,15 +60,15 @@
+ install: all
+ # -c is ignored on Linux, but required on FreeBSD
+       $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8
+-      $(INSTALL) -c -m 755 -s lspci setpci $(DESTDIR)$(SBINDIR)
++      $(INSTALL) -c -m 755 lspci setpci pcimodules $(DESTDIR)$(SBINDIR)
+       $(INSTALL) -c -m 755 update-pciids $(DESTDIR)$(SBINDIR)
+       $(INSTALL) -c -m 644 $(PCI_IDS) $(DESTDIR)$(IDSDIR)
+-      $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
++      $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 pcimodules.8 $(DESTDIR)$(MANDIR)/man8
+ uninstall: all
+-      rm -f $(DESTDIR)$(SBINDIR)/lspci $(DESTDIR)$(SBINDIR)/setpci $(DESTDIR)$(SBINDIR)/update-pciids
++      rm -f $(DESTDIR)$(SBINDIR)/lspci $(DESTDIR)$(SBINDIR)/setpci $(DESTDIR)$(SBINDIR)/update-pciids $(SBINDIR)/pcimodules
+       rm -f $(DESTDIR)$(IDSDIR)/$(PCI_IDS)
+-      rm -f $(DESTDIR)$(MANDIR)/man8/lspci.8 $(DESTDIR)$(MANDIR)/man8/setpci.8 $(DESTDIR)$(MANDIR)/man8/update-pciids.8
++      rm -f $(DESTDIR)$(MANDIR)/man8/lspci.8 $(DESTDIR)$(MANDIR)/man8/setpci.8 $(DESTDIR)$(MANDIR)/man8/update-pciids.8 $(MANDIR)/man8/pcimodules.8
+ pci.ids.gz: pci.ids
+       gzip -9 <$< >$@
+Index: pciutils-2.2.4/lspci.c
+===================================================================
+--- pciutils-2.2.4.orig/lspci.c        2006-09-09 14:32:29.000000000 +0200
++++ pciutils-2.2.4/lspci.c     2006-10-31 10:56:57.000000000 +0100
+@@ -120,8 +120,10 @@
+   d->config = xmalloc(64);
+   d->present = xmalloc(64);
+   memset(d->present, 1, 64);
+-  if (!pci_read_block(p, 0, d->config, 64))
+-    die("Unable to read the standard configuration space header");
++  if (!pci_read_block(p, 0, d->config, 64)) {
++    fprintf(stderr, "Unable to read the standard configuration space header");
++      return NULL;
++  }
+   if ((d->config[PCI_HEADER_TYPE] & 0x7f) == PCI_HEADER_TYPE_CARDBUS)
+     {
+       /* For cardbus bridges, we need to fetch 64 bytes more to get the
+Index: pciutils-2.2.4/pcimodules.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ pciutils-2.2.4/pcimodules.c        2006-10-31 10:51:09.000000000 +0100
+@@ -0,0 +1,185 @@
++/*
++ *    pcimodules:  Load all kernel modules for PCI device currently
++ *      plugged into any PCI slot.
++ *
++ *    Copyright 2000 Yggdrasil Computing, Incorporated
++ *    This file may be copied under the terms and conditions of version 
++ *      two of the GNU General Public License, as published by the Free
++ *      Software Foundation (Cambridge, Massachusetts, USA).
++ *
++ *      This file is based on pciutils/lib/example.c, which has the following
++ *      authorship and copyright statement:
++ *
++ *            Written by Martin Mares and put to public domain. You can do
++ *            with it anything you want, but I don't give you any warranty.
++ */
++
++#include <stdlib.h>
++#include <stdio.h>
++#include <malloc.h>
++#include <string.h>
++#include <unistd.h>
++#include <sys/utsname.h>
++#include <sys/param.h>
++#include <sys/types.h>
++
++#define _GNU_SOURCE
++#include <getopt.h>
++
++#include "pciutils.h"
++
++#define MODDIR        "/lib/modules"
++#define PCIMAP        "modules.pcimap"
++
++#define LINELENGTH    8000 
++
++#define DEVICE_ANY    0xffffffff
++#define VENDOR_ANY    0xffffffff
++
++#include "lib/pci.h"
++
++ const char program_name[] = "lspci";
++
++struct pcimap_entry {
++      unsigned int vendor, subsys_vendor, dev, subsys_dev, class, class_mask;
++      char *module;
++      struct pcimap_entry *next;
++};
++
++static struct pcimap_entry *pcimap_list = NULL;
++
++#define OPT_STRING "h"
++static struct option long_options[] = {
++      {"class",       required_argument,      NULL, 'c'},
++      {"classmask",   required_argument,      NULL, 'm'},
++      {"help",        no_argument,            NULL, 'h'},
++      { 0,            0,                      0,      0}
++};
++
++static unsigned long desired_class;
++static unsigned long desired_classmask; /* Default is 0: accept all classes.*/
++
++void
++read_pcimap(void)
++{
++      struct utsname utsname;
++      char filename[MAXPATHLEN];
++      FILE *pcimap_file;
++      char line[LINELENGTH];
++      struct pcimap_entry *entry;
++      unsigned int driver_data;
++      char *prevmodule = "";
++      char module[LINELENGTH];
++
++      if (uname(&utsname) < 0) {
++              perror("uname");
++              exit(1);
++      }
++      sprintf(filename, "%s/%s/%s", MODDIR, utsname.release, PCIMAP);
++      if ((pcimap_file = fopen(filename, "r")) == NULL) {
++              perror(filename);
++              exit(1);
++      }
++
++      while(fgets(line, LINELENGTH, pcimap_file) != NULL) {
++              if (line[0] == '#')
++                      continue;
++
++              entry = xmalloc(sizeof(struct pcimap_entry));
++
++              if (sscanf(line, "%s 0x%x 0x%x 0x%x 0x%x 0x%x 0x%x 0x%x",
++                         module,
++                         &entry->vendor, &entry->dev,
++                         &entry->subsys_vendor, &entry->subsys_dev,
++                         &entry->class, &entry->class_mask,
++                         &driver_data) != 8) {
++                      fprintf (stderr,
++                              "modules.pcimap unparsable line: %s.\n", line);
++                      free(entry);
++                      continue;
++              }
++
++              /* Optimize memory allocation a bit, in case someday we
++                 have Linux systems with ~100,000 modules.  It also
++                 allows us to just compare pointers to avoid trying
++                 to load a module twice. */
++              if (strcmp(module, prevmodule) != 0) {
++                      prevmodule = xmalloc(strlen(module)+1);
++                      strcpy(prevmodule, module);
++              }
++              entry->module = prevmodule;
++              entry->next = pcimap_list;
++              pcimap_list = entry;
++      }
++      fclose(pcimap_file);
++}
++
++/* Return a filled in pci_access->dev tree, with the device classes
++   stored in dev->aux.
++*/
++static void
++match_pci_modules(void)
++{
++      struct pci_access *pacc;
++      struct pci_dev *dev;
++      unsigned int class, subsys_dev, subsys_vendor;
++      struct pcimap_entry *map;
++      const char *prevmodule = "";
++
++      pacc = pci_alloc();             /* Get the pci_access structure */
++      /* Set all options you want -- here we stick with the defaults */
++      pci_init(pacc);         /* Initialize the PCI library */
++      pci_scan_bus(pacc);     /* We want to get the list of devices */
++      for(dev=pacc->devices; dev; dev=dev->next) {
++              pci_fill_info(dev, PCI_FILL_IDENT | PCI_FILL_BASES);
++              class = (pci_read_word(dev, PCI_CLASS_DEVICE) << 8)
++                      | pci_read_byte(dev, PCI_CLASS_PROG);
++              subsys_dev = pci_read_word(dev, PCI_SUBSYSTEM_ID);
++              subsys_vendor = pci_read_word(dev,PCI_SUBSYSTEM_VENDOR_ID);
++              for(map = pcimap_list; map != NULL; map = map->next) {
++                      if (((map->class ^ class) & map->class_mask) == 0 &&
++                          ((desired_class ^ class) & desired_classmask)==0 &&
++                          (map->dev == DEVICE_ANY ||
++                           map->dev == dev->device_id) &&
++                          (map->vendor == VENDOR_ANY ||
++                           map->vendor == dev->vendor_id) &&
++                          (map->subsys_dev == DEVICE_ANY ||
++                           map->subsys_dev == subsys_dev) &&
++                          (map->subsys_vendor == VENDOR_ANY ||
++                           map->subsys_vendor == subsys_vendor) &&
++                          prevmodule != map->module) {
++                              printf("%s\n", map->module);
++                              prevmodule = map->module;
++                      }
++              }
++
++      }
++      pci_cleanup(pacc);
++}
++
++int
++main (int argc, char **argv)
++{
++      int opt_index = 0;
++      int opt;
++
++      while ((opt = getopt_long(argc, argv, OPT_STRING, long_options,
++                         &opt_index)) != -1) {
++              switch(opt) {
++                      case 'c':
++                              desired_class = strtol(optarg, NULL, 0);
++                              break;
++                      case 'm':
++                              desired_classmask = strtol(optarg, NULL, 0);
++                              break;
++                      case 'h':
++                              printf ("Usage: pcimodules [--help]\n"
++                                      "  Lists kernel modules corresponding to PCI devices currently plugged"
++                                      "  into the computer.\n");
++              }
++      }       
++
++      read_pcimap();
++      match_pci_modules();
++      return 0;
++}
+Index: pciutils-2.2.4/pcimodules.man
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ pciutils-2.2.4/pcimodules.man      2006-10-31 10:51:09.000000000 +0100
+@@ -0,0 +1,92 @@
++.TH pcimodules 8 "@TODAY@" "@VERSION@" "Linux PCI Utilities"
++.IX pcimodules
++.SH NAME
++pcimodules \- List kernel driver modules available for all currently plugged
++in PCI devices
++.SH SYNOPSIS
++.B pcimodules
++.RB [ --class class_id ]
++.RB [ --classmask mask ]
++.RB [ --help ]
++.SH DESCRIPTION
++.B pcimodules
++lists all driver modules for all currently plugged in PCI devices.
++.B pcimodules
++should be run at boot time, and whenever a PCI device is "hot plugged"
++into the system.  This can be done by the following Bourne shell syntax:
++.IP
++      for module in $(pcimodules) ; do
++.IP
++              modprobe -s -k "$module"
++.IP
++      done
++.PP
++When a PCI device is removed from the system, the Linux kernel will
++decrement a usage count on PCI driver module.  If this count drops
++to zero (i.e., there are no PCI drivers), then the
++.B modprobe -r
++process that is normally configured to run from cron every few minutes
++will eventually remove the unneeded module.
++.PP
++The --class and --classmask arguments can be used to limit the search
++to certain classes of PCI devices.  This is useful, for example, to
++generate a list of ethernet card drivers to be loaded when the kernel
++has indicated that it is trying to resolve an unknown network interface.
++.PP
++Modules are listed in the order in which the PCI devices are physically
++arranged so that the computer owner can arrange things like having scsi
++device 0 be on a controller that is not alphabetically the first scsi
++controller.
++.SH OPTIONS
++.TP
++.B --class class --classmask mask
++.PP
++--class and --classmask limit the search to PCI
++cards in particular classes.  These arguments are always used together.
++The arguments to --class and --classmask
++can be given as hexadecimal numbers by prefixing a leading "0x".
++Note that the classes used by pcimodules are in "Linux" format,
++meaning the class value that you see with lspci would be shifted
++left eight bits, with the new low eight bits programming interface ID.
++An examples of how to use class and classmask is provided below.
++.B --help, -h
++Print a help message and exit.
++.SH EXAMPLES
++.TP
++pcimodules
++lists all modules corresponding to currently plugged in PCI devices.
++.TP
++pcimodules --class 0x200000 --classmask 0xffff00
++lists all modules corresponding to currently plugged in ethernet PCI devices.
++.SH FILES
++.TP
++.B /lib/modules/<kernel-version>/modules.pcimap
++This file is automatically generated by
++.B depmod,
++and used by
++.B pcimodules
++to determine which modules correspond to which PCI ID's.
++.TP
++.B /proc/bus/pci
++An interface to PCI bus configuration space provided by the post-2.1.82 Linux
++kernels. Contains per-bus subdirectories with per-card config space files and a
++.I devices
++file containing a list of all PCI devices.
++
++.SH SEE ALSO
++.BR lspci (8)
++
++.SH MAINTAINER
++The Linux PCI Utilities are maintained by Martin Mares <mj@suse.cz>.
++
++.SH AUTHOR
++.B pcimodules
++was written by Adam J. Richter <adam@yggdrasil.com>, based on public
++domain example code by Martin Mares <mj@suse.cz>.
++
++.SH COPYRIGHT
++.B pcimodules
++is copyright 2000, Yggdrasil Computing, Incorporated, and may
++be copied under the terms and conditions of version 2 of the GNU
++General Public License as published by the Free Software Foundation
++(Cambrige, Massachusetts, United States of America).
diff --git a/meta/packages/pciutils/pciutils_2.2.4.bb b/meta/packages/pciutils/pciutils_2.2.4.bb
new file mode 100644 (file)
index 0000000..0cd335e
--- /dev/null
@@ -0,0 +1,38 @@
+DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
+to PCI bus configuration space and several utilities based on this library.'
+DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
+SECTION = "console/utils"
+HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
+LICENSE = "GPLv2"
+DEPENDS = "zlib"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
+          file://configure.patch;patch=1 \
+           file://configure-uclibc.patch;patch=1 \
+          file://pcimodules-pciutils.diff;patch=1"
+
+PARALLEL_MAKE = ""
+
+PR="r1"
+
+do_configure () {
+       (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
+}
+
+export PREFIX = "${D}${prefix}"
+export SBINDIR = "${D}${sbindir}"
+export SHAREDIR = "${D}${datadir}"
+export MANDIR = "${D}${mandir}"
+
+LDFLAGS += "-lz"
+
+do_install () {
+       oe_runmake install
+}
+do_install_append () {
+       install -d ${D}/${prefix}/share
+       install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
+}
+
+PACKAGES =+ "pciutils-ids"
+FILES_pciutils-ids="${prefix}/share/pci.ids"