]> code.ossystems Code Review - openembedded-core.git/commitdiff
liberror-perl: inherit ptest-perl
authorTim Orling <timothy.t.orling@linux.intel.com>
Sun, 4 Mar 2018 12:41:51 +0000 (04:41 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Mar 2018 14:13:58 +0000 (06:13 -0800)
* Enable ptest by inheriting new ptest-perl.bbclass

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/liberror-perl_0.17025.bb

index 251b13195ad2dd3286baa6cd816fa21cc7205235..f6dc30d0774b76bb88aae75c00bc9a04338bc80f 100644 (file)
@@ -18,11 +18,16 @@ SRC_URI[sha256sum] = "6c9f474ad3d4fe0cabff6b6be532cb1dd348245986d4a6b600ad921d5c
 
 S = "${WORKDIR}/Error-${PV}"
 
-inherit cpan
+inherit cpan ptest-perl
 
 do_compile() {
        export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
        cpan_do_compile
 }
 
+do_install_prepend() {
+       # test requires "-T" (taint) command line option
+       rm -rf ${B}/t/pod-coverage.t
+}
+
 BBCLASSEXTEND = "native"