]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils 0.163: remove do_configure_prepend
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 10 Jul 2015 07:14:47 +0000 (00:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jul 2015 21:53:19 +0000 (22:53 +0100)
It is derived from elfutils 0.148, but 0.162 doesn't need them, it
doesn't need i386_dis.h or x86_64_dis.h either, there are the same two
files in the source, so move elfutils/i386_dis.h to
elfutils-0.148/i386_dis.h and elfutils/x86_64_dis.h to
elfutils-0.148/x86_64_dis.h for elfutils 0.148 only.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/elfutils/elfutils-0.148/i386_dis.h [moved from meta/recipes-devtools/elfutils/elfutils/i386_dis.h with 100% similarity]
meta/recipes-devtools/elfutils/elfutils-0.148/x86_64_dis.h [moved from meta/recipes-devtools/elfutils/elfutils/x86_64_dis.h with 100% similarity]
meta/recipes-devtools/elfutils/elfutils_0.163.bb

index b34bfdd4b9b744586d11f4acff4d48df9fed6427..c4fdabdb3140a94f6978ce51214697780fba86e1 100644 (file)
@@ -42,22 +42,12 @@ SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.161.patch"
 # which can not pass the cross compiling, so let's work around it by adding 2 .h files
 # along with the do_configure_prepend()
 
-SRC_URI += "\
-        file://i386_dis.h \
-        file://x86_64_dis.h \
-"
 inherit autotools gettext
 
 EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
 EXTRA_OECONF_append_class-native = " --without-bzlib"
 EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
 
-do_configure_prepend() {
-       sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
-
-       cp ${WORKDIR}/*dis.h ${S}/libcpu
-}
-
 do_install_append() {
        if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
                rm ${D}${bindir}/eu-objdump