]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub-efi: install to /boot/
authorCalifornia Sullivan <california.l.sullivan@intel.com>
Thu, 1 Mar 2018 02:15:00 +0000 (18:15 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Mar 2018 14:23:06 +0000 (06:23 -0800)
Since /boot/ will be recipe/package controlled now we can't just deploy.

Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub-bootconf_1.00.bb
meta/recipes-bsp/grub/grub-efi_2.02.bb

index d376fde68b1536f7eb3c395e8dd673bd96ef01eb..750f8c808a8e420a9d88b33f6910fbe9e3335ff2 100644 (file)
@@ -23,7 +23,7 @@ do_install() {
        install -d ${D}/boot
        install -d ${D}/boot/EFI
        install -d ${D}/boot/EFI/BOOT
-       install -m 0744 grub-bootconf ${D}/boot/EFI/BOOT/grub.cfg
+       install grub-bootconf ${D}/boot/EFI/BOOT/grub.cfg
 }
 
 FILES_${PN} = "/boot/EFI/BOOT/grub.cfg"
index d5aa64c75f72487804495195b601df5892b32f6d..c5a68f01cef5084ebcd9fd0d41d4d9e7c85bea61 100644 (file)
@@ -3,7 +3,7 @@ require grub2.inc
 GRUBPLATFORM = "efi"
 
 DEPENDS_append_class-target = " grub-efi-native"
-RDEPENDS_${PN}_class-target = "diffutils freetype grub-common"
+RDEPENDS_${PN}_class-target = "diffutils freetype grub-common virtual/grub-bootconf"
 
 SRC_URI += " \
            file://cfg \
@@ -36,6 +36,28 @@ EXTRA_OECONF += "--enable-efiemu=no"
 # and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
 CFLAGS_append_class-native = " -Wno-error=trampolines"
 
+do_mkimage() {
+       cd ${B}
+       # Search for the grub.cfg on the local boot media by using the
+       # built in cfg file provided via this recipe
+       grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
+                      -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
+                      ${GRUB_BUILDIN}
+}
+
+addtask mkimage before do_install after do_compile
+
+do_mkimage_class-native() {
+       :
+}
+
+do_install_append_class-target() {
+       install -d ${D}/boot
+       install -d ${D}/boot/EFI
+       install -d ${D}/boot/EFI/BOOT
+       install -m 644 ${B}/${GRUB_IMAGE} ${D}/boot/EFI/BOOT/
+}
+
 do_install_class-native() {
        install -d ${D}${bindir}
        install -m 755 grub-mkimage ${D}${bindir}
@@ -57,11 +79,6 @@ GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \
                  efi_gop iso9660 configfile search loadenv test"
 
 do_deploy() {
-       # Search for the grub.cfg on the local boot media by using the
-       # built in cfg file provided via this recipe
-       grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
-                      -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
-                      ${GRUB_BUILDIN}
        install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
 }
 
@@ -72,7 +89,10 @@ do_deploy_class-native() {
 addtask deploy after do_install before do_build
 
 FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
-                "
+               ${datadir}/grub \
+               /boot/EFI/BOOT/${GRUB_IMAGE} \
+               "
+
 
 # 64-bit binaries are expected for the bootloader with an x32 userland
 INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"