]> code.ossystems Code Review - openembedded-core.git/commitdiff
pkgconfig: Add a manual dependency of pkgconfig(pkg-config)
authorMark Hatle <mark.hatle@windriver.com>
Fri, 30 Nov 2012 02:54:42 +0000 (20:54 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:33 +0000 (12:30 +0000)
The libtelepathy-glib-dev package contains a .pc file that has a requires
of pkgconfig(pkg-config) > 0.21 in it.  In order to satisfy this requirement
we add a manual RPROVIDE to the pkgconfig package.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/pkgconfig/pkgconfig.inc
meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
meta/recipes-devtools/pkgconfig/pkgconfig_git.bb

index 83a9cdf80aed6c726be8e77723eb875e7f13274b..27d407170c0635a4ac9457d046a383f353fabe0e 100644 (file)
@@ -37,3 +37,8 @@ BBCLASSEXTEND = "native nativesdk"
 # files.
 FILES_${PN}-dev = ""
 FILES_${PN} += "${datadir}/aclocal/pkg.m4"
+
+# When using the RPM generated automatic package dependencies, some packages
+# will end up requiring 'pkgconfig(pkg-config)'.  Allow this behavior by
+# specifying an appropriate provide.
+RPROVIDES_${PN} += "pkgconfig(pkg-config) (= ${PV})"
index 1e60c54cbf3df1f892cbbca7b9be9fabfb2651e2..d0a2b1f9e501c951f5fa64158405ca20302eee39 100644 (file)
@@ -1,6 +1,6 @@
 require pkgconfig.inc
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI[md5sum] = "a3270bab3f4b69b7dc6dbdacbcae9745"
 SRC_URI[sha256sum] = "3ba691ee2431f32ccb8efa131e59bf23e37f122dc66791309023ca6dcefcd10e"
index 627199291070866fb6ec0da0b89ba9a3a88bf08c..d5ec8fcf793d05a2d841913420c16e269d16c5a7 100644 (file)
@@ -8,6 +8,7 @@ S = "${WORKDIR}/git/"
 
 SRCREV = "66d49f1375fec838bcd301bb4ca2ef76cee0e47c"
 PV = "0.23+git${SRCPV}"
+PR = "r1"
 
 DEFAULT_PREFERENCE = "-1"