]> code.ossystems Code Review - openembedded-core.git/commitdiff
db: Use cross libtool
authorKhem Raj <raj.khem@gmail.com>
Tue, 12 Jul 2016 17:10:17 +0000 (10:10 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jul 2016 09:24:51 +0000 (10:24 +0100)
Reintroduce the use of cross-libtool when building the target package
this fails otherwise with clang

| ./libtool --mode=execute true db_printlog
| /usr/lib/libstdc++.so: file not recognized: File format not recognized
| clang-3.9: error: linker command failed with exit code 1 (use -v to see invocation)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/db/db_5.3.28.bb
meta/recipes-support/db/db_6.0.30.bb

index 6b0e76b1a339e3d691829215723bcd5fb4f44a06..0b51a1d4403b3b564dd847682b9cea0848f89ab7 100644 (file)
@@ -70,6 +70,7 @@ MUTEX = ""
 MUTEX_arm = "${ARM_MUTEX}"
 MUTEX_armeb = "${ARM_MUTEX}"
 EXTRA_OECONF += "${MUTEX} STRIP=true"
+EXTRA_OEMAKE_append_class-target = " LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
 
 AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
 
index 08528206f9847a4ca3fe2f86780dd90b8df80212..072cbdf217ef62f4b80c62b6c21d43c186db5c6a 100644 (file)
@@ -87,6 +87,7 @@ MUTEX = ""
 MUTEX_arm = "${ARM_MUTEX}"
 MUTEX_armeb = "${ARM_MUTEX}"
 EXTRA_OECONF += "${MUTEX}"
+EXTRA_OEMAKE_append_class-target = " LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
 EXTRA_OEMAKE += "STRIP=true"
 
 do_compile_prepend() {