]> code.ossystems Code Review - openembedded-core.git/commitdiff
parted: refresh patches
authorRoss Burton <ross.burton@intel.com>
Thu, 8 Mar 2018 18:17:49 +0000 (20:17 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Mar 2018 17:16:02 +0000 (09:16 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/parted/files/no_check.patch
meta/recipes-extended/parted/files/syscalls.patch

index 58d8db44264880af5ae45633f9918617f1f42941..e6a26d11a5c287e4ab059b837226c2b2eff1f2fb 100644 (file)
@@ -5,12 +5,12 @@ it to be disabled.
 
 RP - 4/11/08
 
-Index: parted-1.9.0/configure.ac
+Index: parted-3.2/configure.ac
 ===================================================================
---- parted-1.9.0.orig/configure.ac     2009-07-23 18:52:08.000000000 +0100
-+++ parted-1.9.0/configure.ac  2010-02-02 14:13:56.013905093 +0000
-@@ -477,7 +477,7 @@
- AM_CONDITIONAL([BUILD_LINUX], [test "$OS" = linux])
+--- parted-3.2.orig/configure.ac
++++ parted-3.2/configure.ac
+@@ -555,7 +555,7 @@ AC_CHECK_HEADER([execinfo.h], [
+ AM_CONDITIONAL([COMPILE_FOR_S390], [test "$host_cpu" = s390 || test "$host_cpu" = s390x])
  
  dnl check for "check", unit testing library/header
 -PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no)
index e9bbe9a956d72483650355a1708b6e70e4791af7..93205a0a8040dc976e2775f122829a35437aaa1d 100644 (file)
@@ -4,10 +4,10 @@ Upstream-Status: Pending
  libparted/arch/linux.c |   13 +++++++++++++
  1 file changed, 13 insertions(+)
 
-Index: parted-1.9.0/libparted/arch/linux.c
+Index: parted-3.2/libparted/arch/linux.c
 ===================================================================
---- parted-1.9.0.orig/libparted/arch/linux.c   2009-07-23 18:52:08.000000000 +0100
-+++ parted-1.9.0/libparted/arch/linux.c        2010-02-02 14:14:16.523904768 +0000
+--- parted-3.2.orig/libparted/arch/linux.c
++++ parted-3.2/libparted/arch/linux.c
 @@ -17,6 +17,8 @@
  
  #define PROC_DEVICES_BUFSIZ 16384
@@ -16,8 +16,8 @@ Index: parted-1.9.0/libparted/arch/linux.c
 +
  #include <config.h>
  #include <arch/linux.h>
-@@ -1477,12 +1479,14 @@
+ #include <linux/blkpg.h>
+@@ -1696,12 +1698,14 @@ linux_refresh_close (PedDevice* dev)
  
  #if SIZEOF_OFF_T < 8
  
@@ -32,7 +32,7 @@ Index: parted-1.9.0/libparted/arch/linux.c
  
  loff_t
  llseek (unsigned int fd, loff_t offset, unsigned int whence)
-@@ -1490,11 +1494,20 @@
+@@ -1709,11 +1713,20 @@ llseek (unsigned int fd, loff_t offset,
          loff_t result;
          int retval;